Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000990TestLinkReportspublic2007-08-23 14:432008-11-07 19:46
Reportermike_h 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 3 
Fixed in Version1.8 Beta 1 
Summary0000990: Order of build numbers by name of the build and not by version number
DescriptionIt would be nice if the builds are ordered by their version number in the testreport and in the "Build Management". Currently the builds are ordered by their names which can be a problem (see example in additional information).
Additional Information- Create Testproject "BuildTest"
- Create Testplan "Testplan"
- Create Builds:
-- 1.0
-- 1.1
-- 1.2
-- 1.10

-> The builds are then ordered in the testreport and in the "Build Management" as follows:
-- 1.0
-- 1.1
-- 1.10
-- 1.2

-> This order can be missleading in the testreport, because then it seems for the user that build 1.10 has been created before build 1.2 (see attached screenshot of testreport "screenshot_order_builds_testreport.jpg").
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 2.0.0.6
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon screenshot_order_builds_testreport.JPG [^] (60,857 bytes) 2007-08-23 14:43


? file icon testplan.class.php [^] (38,569 bytes) 2007-08-23 15:00

- Relationships

-  Notes
(0001955)
mike_h (reporter)
2007-08-23 14:58

I tried to solve it by editing testplan.class.php (see attached file). There I created a function called sortBuildNames($a, $b) (see lines 871-889), which has been used for an uasort of the $recordset (see line 924).
(0001956)
fman (administrator)
2007-08-23 16:30

OK, but IMHO an option at user interface level is need to allow users the order type.

I will give a look to your code .
(0001959)
mike_h (reporter)
2007-08-23 16:43

Yes I think too that it would be nice to give the user the possibility to set the order of the builds.

- Issue History
Date Modified Username Field Change
2007-08-23 14:43 mike_h New Issue
2007-08-23 14:43 mike_h File Added: screenshot_order_builds_testreport.JPG
2007-08-23 14:43 mike_h Browser => Firefox 2.0.0.6
2007-08-23 14:58 mike_h Note Added: 0001955
2007-08-23 15:00 mike_h File Added: testplan.class.php
2007-08-23 16:30 fman Note Added: 0001956
2007-08-23 16:43 mike_h Note Added: 0001959
2007-11-09 02:09 fman Status new => resolved
2007-11-09 02:09 fman Fixed in Version => next development version (1.8 Beta1)
2007-11-09 02:09 fman Resolution open => fixed
2007-11-09 02:09 fman Assigned To => fman
2008-06-03 16:49 mhavlat Fixed in Version next development version (1.8 Beta1) => 1.8 Beta 1
2008-11-07 19:46 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker