Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000951TestLinkUsers and Rightspublic2007-07-25 13:512007-09-15 04:25
Reportermike_h 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 3 
Fixed in Version1.7.0 final 
Summary0000951: Inherit testplan user role from testproject user role
Descriptioncreate all new users with "no rights" role and assign the "leader" role only to some testprojects the user belongs to. If the testplan role can somehow inherit from the belonging testproject role it would not be necessary to set the belonging testplan roles to another state than "inherited" (except you want to exclude some users from some testplans).
Additional Information- login as user with global admin rights
- create user "testuser" with <no rights>
- create project "tp" and assign testproject role "admin" to user "testuser" for testproject "tp"
- login as user "testuser"
-> user cannot add new testplans, because it inherits from global rights -> if testplan rights can inherit from testproject-rights it would be possible add testplans.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 2.0.0.5
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon screenshot_testuser_start.JPG [^] (92,017 bytes) 2007-08-01 13:45


jpg file icon screenshot_admin_role.JPG [^] (116,450 bytes) 2007-08-01 13:53


jpg file icon screenshot_no_rights_role.JPG [^] (118,966 bytes) 2007-08-01 13:56


jpg file icon screenshot_testproject_tp1_rights.JPG [^] (59,630 bytes) 2007-08-01 13:59


jpg file icon screenshot_testplan_testplan1_rights.JPG [^] (59,056 bytes) 2007-08-01 14:03


jpg file icon screenshot_no_testplan_rights_testproject_admin.JPG [^] (56,886 bytes) 2007-08-21 15:25


zip file icon plan.core.inc.zip [^] (2,992 bytes) 2007-08-22 14:03

- Relationships

-  Notes
(0001894)
fman (administrator)
2007-07-30 19:42

I will use your example, but my first tests signals, that TL works the way you want:
Test Plan inherits ROLEfrom Test Projects
Test Projects inherits ROLE from Users
(0001900)
mike_h (reporter)
2007-07-31 23:08

I am sorry but i didn't realize that I have to push the "ok" button in the upper right corner. Then the screen is refreshed and the testuser can now create testplans.

But unfortunately the testuser cannot fill the created testplan with testcases because it seems that the user has (due to the <inherited> rights for all testplans) no rights to edit or execute specific testplans. So it seems that the testplan role of the testuser still inherits from the global <no rights>-role of the testuser and not of the testproject, where it should be admin. Sorry for the wrong information above.
(0001901)
fman (administrator)
2007-07-31 23:18

Please do an screenshot of rights for the role you have problems and attach here
(0001903)
mike_h (reporter)
2007-08-01 14:06

The screenshots I added show:
screenshot_testuser_start: The main window of the testuser that has been created with admin role for the testproject but <no rights> as global rights.
screenshot_admin_role: The standard role "admin" and its rights
screenshot_no_rights_role: The standard role "<no rights>" and its rights
screenshot_testproject_tp1_rights: The role settings for the users for testproject tp1
screenshot_testplan_testplan1_rights: The role settings for the users for testplan1, which is part of testproject tp1
(0001947)
mike_h (reporter)
2007-08-21 15:24

In the newest tarball (SNAPSHOT-HEAD-2007-08-21.tar.bz2) I see that the testplan-roles are inherited from the testproject-roles (in the dropdown-menue for the roles for the testplan) in the "Assign test plan roles"-interface but the user has still no access to the testplans due to the global <no rights> role.

(See attached screenshot "screenshot_no_testplan_rights_testproject_admin.JPG" -> User MHa has global <no rights>-role but "admin"-role for the current testproject and testplan role should inherit from the testproject role -> there is an active testplan called "Testplan" but the user MHa cannot see the testplan.)
(0001948)
fman (administrator)
2007-08-21 15:28

OK, I will test ASAP
(0001952)
fman (administrator)
2007-08-22 14:04

Please use attached file and retest.
Let me know if everything is OK.
I've done only a couple of tests.
(0001953)
mike_h (reporter)
2007-08-22 21:00

I have used the file you have attached and it works with the tests I have done! Thanks!

- Issue History
Date Modified Username Field Change
2007-07-25 13:51 mike_h New Issue
2007-07-25 13:51 mike_h Browser => Firefox 2.0.0.5
2007-07-30 19:42 fman Note Added: 0001894
2007-07-31 23:08 mike_h Note Added: 0001900
2007-07-31 23:18 fman Note Added: 0001901
2007-08-01 13:45 mike_h File Added: screenshot_testuser_start.JPG
2007-08-01 13:53 mike_h File Added: screenshot_admin_role.JPG
2007-08-01 13:56 mike_h File Added: screenshot_no_rights_role.JPG
2007-08-01 13:59 mike_h File Added: screenshot_testproject_tp1_rights.JPG
2007-08-01 14:03 mike_h File Added: screenshot_testplan_testplan1_rights.JPG
2007-08-01 14:06 mike_h Note Added: 0001903
2007-08-21 15:24 mike_h Note Added: 0001947
2007-08-21 15:25 mike_h File Added: screenshot_no_testplan_rights_testproject_admin.JPG
2007-08-21 15:28 fman Note Added: 0001948
2007-08-22 14:03 fman File Added: plan.core.inc.zip
2007-08-22 14:04 fman Note Added: 0001952
2007-08-22 21:00 mike_h Note Added: 0001953
2007-08-22 22:14 fman Status new => resolved
2007-08-22 22:14 fman Fixed in Version => next version
2007-08-22 22:14 fman Resolution open => fixed
2007-08-22 22:14 fman Assigned To => fman
2007-09-15 04:25 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker