Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000937TestLinkThird party componentspublic2007-07-08 18:452008-11-07 19:46
Reporterfawel 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.0 RC 3 
Fixed in Version1.8 Beta 1 
Summary0000937: build a fckeditor replacement
DescriptionHello,

I have created a fckeditor replacement for editing testcases.

See attached file. There are 2 folders - fckeditor and tinymce.

fckeditor:
-> some changes to load fckeditor files only once time
-> fast on ie, but still slow on firefox

tinymce
-> switched from fckeditor to tiny_mce
-> very fast on ie, firefox and opera
-> small toolbar for faster load, maybe some buttons could be added (font, size, color, images, links...)
-> textarea size optimized for 1024x768
-> tinymce is released under LGPL

For testing purposes only. There should be done some changes (toolbar set, use for all testareas in testlink). I could to that... Please contact me, if you interested.

(tested with ie 7, firefox 2 and opera 9 on apache & php 5)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon editor.zip [^] (593,530 bytes) 2007-07-08 18:45

- Relationships
related to 0001216closedfman Config. option to choose Web editor type, including no editor 

-  Notes
(0001857)
fman (administrator)
2007-07-09 14:29

Good, I've not see your code, but I hope has been written as modular as possible
to enable change of editor just with a config option
(0001869)
fawel (reporter)
2007-07-12 02:09

It was planned as complete replacement. I think it will be the best solution because of poor fck editor performance.

I could also build change with config option, if you wish.

But before I do, please someone run a test and give a look on code.

- Issue History
Date Modified Username Field Change
2007-07-08 18:45 fawel New Issue
2007-07-08 18:45 fawel File Added: editor.zip
2007-07-09 14:29 fman Note Added: 0001857
2007-07-12 02:09 fawel Note Added: 0001869
2007-12-03 16:52 fman Relationship added related to 0001216
2007-12-03 16:53 fman Status new => resolved
2007-12-03 16:53 fman Fixed in Version => next development version (1.8 Beta1)
2007-12-03 16:53 fman Resolution open => fixed
2007-12-03 16:53 fman Assigned To => fman
2008-06-03 16:49 mhavlat Fixed in Version next development version (1.8 Beta1) => 1.8 Beta 1
2008-11-07 19:46 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker