Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008908TestLinkExport/Importpublic2020-04-23 15:002020-04-23 20:17
Reportertna011110 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMACOSCatalinaOS Version10.15.4
Product Version1.9.20 
Fixed in Version1.9.20_fixed 
Summary0008908: Unable to import requirements custom field
DescriptionI exported requirements that has four custom fields using TestLink 1.9.19 (Metonic cycle) in Windows and imported into TestLink 1.9.20 on a MAC. Everything imported except for the custom fields. Import file is attached.

Steps To Reproduce  * Add a requirement with values for Custom Fields: CompMech, VSACategory, VSAControls, and Exceptions in TestLink 1.9.19 (windows 10)
  * Export this requirements in xml
  * Import this XML in Requirement to TestLink 1.9.20 (MAC Catalina)

Requirement is create but the custom fields are not imported.
Additional InformationAfter an unsuccessful import of the custom fields without making any changes to 1.9.20, I also looked at http://mantis.testlink.org/view.php?id=8853 [^] and saw that it was fixed in version 1.9.20. However, when I looked at the fix and comparing it to my own version it seems to be slightly different. "Case 'name'" was missing. So I stopped all of the services on the MAC. manually changed cfield_mgr.class.php to match: https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/4e3253b05fb768d66064ab64b49734e654260320 [^] . I restarted all my services and tried to import again. Same result. The requirements custom fields still did not import.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome Version 81.0.4044.122 (Official Build) (64-bit)
PHP VersionZend Engine v3.3.11
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon Access Design Patterns and Requirements-req-spec.xml [^] (1,948 bytes) 2020-04-23 15:00

- Relationships

-  Notes
(0029616)
fman (administrator)
2020-04-23 18:17

Please provide the XML export of your custom fields
(0029617)
fman (administrator)
2020-04-23 18:29

just tested with full branch testlink_1_9_20_fixed -> no issues
(0029619)
tna011110 (reporter)
2020-04-23 19:09

I will update my installation. Thank you and sorry for wasting your time.

- Issue History
Date Modified Username Field Change
2020-04-23 15:00 tna011110 New Issue
2020-04-23 15:00 tna011110 File Added: Access Design Patterns and Requirements-req-spec.xml
2020-04-23 18:17 fman Note Added: 0029616
2020-04-23 18:29 fman Note Added: 0029617
2020-04-23 18:30 fman QA Team - Task Workflow Status => READY FOR TESTING
2020-04-23 18:30 fman Status new => resolved
2020-04-23 18:30 fman Fixed in Version => 1.9.20_fixed
2020-04-23 18:30 fman Resolution open => fixed
2020-04-23 18:30 fman Assigned To => fman
2020-04-23 19:09 tna011110 Note Added: 0029619
2020-04-23 20:17 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker