Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008777TestLinkBuild Managementpublic2019-10-01 05:242019-10-04 12:37
ReporterasdHarry 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformXAMPPOSWindows 10OS Version
Product Version1.9.19.01 (1.9.19 fixes) 
Fixed in Version 
Summary0008777: DB Access Error when click 'Test Execution'
DescriptionI freshly installed TL 1.9.20 by using XAMPP with PHP 7.3.9 and MariaDB 10.4.6 on Windows 10. Everything seems to be fine except this 'DB Access Error' after click 'Test Execution'. The error message is below:

DB Access Error - debug_print_backtrace() OUTPUT START
 ATTENTION: Enabling more debug info will produce path disclosure weakness (CWE-200)
            Having this additional Information could be useful for reporting
            issue to development TEAM.
 ==============================================================================
#0 database->exec_query() called at [C:\xampp\htdocs\testlink\lib\functions\database.class.php:718]
#1 database->fetchColumnsIntoMap() called at [C:\xampp\htdocs\testlink\lib\functions\testplan.class.php:2015]
0000002 testplan->get_builds_for_html_options() called at [C:\xampp\htdocs\testlink\lib\functions\tlTestCaseFilterControl.class.php:1188]
0000003 tlTestCaseFilterControl->init_setting_build() called at [C:\xampp\htdocs\testlink\lib\functions\tlTestCaseFilterControl.class.php:548]
0000004 tlTestCaseFilterControl->init_settings() called at [C:\xampp\htdocs\testlink\lib\functions\tlFilterControl.class.php:246]
0000005 tlFilterControl->__construct() called at [C:\xampp\htdocs\testlink\lib\functions\tlTestCaseFilterControl.class.php:330]
0000006 tlTestCaseFilterControl->__construct() called at [C:\xampp\htdocs\testlink\lib\execute\execNavigator.php:29]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MariaDB 10.4.6
BrowserChrome
PHP Version7.3.9
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon error.png [^] (31,012 bytes) 2019-10-01 05:24

- Relationships

-  Notes
(0029230)
asdHarry (reporter)
2019-10-01 05:26

And I have modified php.ini to change 'max_input_vars' from 1000 to 10000.
(0029233)
fman (administrator)
2019-10-01 17:45

please provide detailed steps to reproduce, step by step
(0029240)
asdHarry (reporter)
2019-10-04 01:36
edited on: 2019-10-04 02:01

After a simple restart of servers, the problem had gone. Should've done that at the first place. Sorry for disturbance and thank you.

(0029241)
fman (administrator)
2019-10-04 12:37

oh! Good!,

- Issue History
Date Modified Username Field Change
2019-10-01 05:24 asdHarry New Issue
2019-10-01 05:24 asdHarry File Added: error.png
2019-10-01 05:26 asdHarry Note Added: 0029230
2019-10-01 17:45 fman Note Added: 0029233
2019-10-03 06:30 fman Assigned To => fman
2019-10-03 06:30 fman Status new => feedback
2019-10-04 01:36 asdHarry Note Added: 0029240
2019-10-04 01:36 asdHarry Status feedback => assigned
2019-10-04 02:01 asdHarry Note Edited: 0029240 View Revisions
2019-10-04 12:37 fman Note Added: 0029241
2019-10-04 12:37 fman QA Team - Task Workflow Status => TBD
2019-10-04 12:37 fman Status assigned => closed
2019-10-04 12:37 fman Resolution open => no change required



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker