Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008739TestLinkFilterspublic2019-08-12 13:272019-08-14 16:32
ReporterEDT 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.9.19 (2019 Q1) 
Fixed in Version1.9.20 Raijing DEV 
Summary0008739: Test Specification - Filter by Keyword - malfunction with parentheses
DescriptionThe Test Suite filter doesn't work properly when searching for a word preceded by left parentheses. The only way to see the wanted result is by searching for "(<word>".
 
It works fine with the right parentheses though, I didn't test with any other special characters.
Steps To ReproduceCreate two Test Suites, named "TS good" and "TS (bad)".

Search for "bad": no TS is presented in the "results preview" section (inside the Test Suite combo).
Search for "(bad": the TS is presented.
Search for "bad)": the TS is presented.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version5.6.7
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon unnamed.png [^] (27,210 bytes) 2019-08-13 13:10


png file icon Screen Shot 2019-08-14 at 17.08.55.png [^] (23,057 bytes) 2019-08-14 15:16


png file icon Screen Shot 2019-08-14 at 17.09.17.png [^] (26,873 bytes) 2019-08-14 15:16


png file icon Screen Shot 2019-08-14 at 17.09.37.png [^] (40,748 bytes) 2019-08-14 15:16


png file icon Screen Shot 2019-08-14 at 17.09.50.png [^] (26,039 bytes) 2019-08-14 15:17

- Relationships

-  Notes
(0029080)
fman (administrator)
2019-08-13 09:32

Thanks for reporting
(0029081)
fman (administrator)
2019-08-13 09:40
edited on: 2019-08-13 09:40

Please provide detailed steps to reproduce.

(0029082)
fman (administrator)
2019-08-13 09:43

Code Base: latest code from github

create test project
create test suite TS-100 (UNDERHOOD)
use the search box present in the same area where the test project hmtl select is displayed
search UN
test suite found
(0029084)
EDT (reporter)
2019-08-13 13:11

I've just uploaded an example from my environment.
I can try to reproduce it in a new local environment once I have the time to do it.
(0029087)
fman (administrator)
2019-08-13 17:08

OK, now is a little bit clear, that's why detailed info is needed, you are having issues with the KEYWORD filtering, but the filtering is done in a jQuery component chosen.
This is a very BIG difference
(0029090)
fman (administrator)
2019-08-13 19:35

No issue this is the way the chosen search works.

closing
(0029091)
fman (administrator)
2019-08-13 19:35

not an issue
(0029093)
EDT (reporter)
2019-08-14 07:40

The issue is about the Test Suite search, you can see in the uploaded images that the Test Suite combo box is opened and that there is a magnifier icon bellow.

The Keyword search has no magnifier.

I understand that this might be a jQuery component related issue, however this behavior is not correct and can lead to wrong results.
(0029095)
fman (administrator)
2019-08-14 14:59
edited on: 2019-08-14 15:18

If the issue is present in jQuery component is clear that I can do nothing to solve it, I hope you understand this.

I've just checked in the chosen site and it seems to work OK, you can try it to verify the behavior https://harvesthq.github.io/chosen/. [^]

I'm going to check is there is something in the way the component is configured in TestLink

Doing some tests seems to provide these answers
example
There is a place here


search hits the word first letter or the firts letter after an space

You can give a look at the images of the different examples I've uploaded

(0029097)
fman (administrator)
2019-08-14 15:25

some info (to be analyzed)
https://stackoverflow.com/questions/9274362/changing-search-behavior-in-jquery-plugin-chosen [^]
(0029098)
EDT (reporter)
2019-08-14 15:26
edited on: 2019-08-14 16:02

Hi!

Googling for Chosen and this issue I found a very useful link: https://github.com/harvesthq/chosen/issues/121 [^]

In this link it's shown that Chosen's default behavior not only omits results if the typed text starts with parentheses but it also omits a result that doesn't start with the type text. In the link you posted, you'll have no results if you search for "tates", but United States is a valid value.

Apparently there's a parameter that might be used to improve this behavior, search_contains:true, but I'm currently dealing with other tasks.

I'll give an update if I get find out anything else before you, but I think this could/should be tweaked in TestLink even though it is an external tool.

EDIT: finally got it, I added the referred property in inc_filter_panel.tpl, in the following lines:

jQuery(".chosen-select").chosen({ width: "85%" , allow_single_deselect: true});
jQuery('select[data-cfield="list"]').chosen({ width: "85%" , allow_single_deselect: true});

And now everything's fine! Thank you!

(0029099)
fman (administrator)
2019-08-14 16:21
edited on: 2019-08-14 16:22

https://harvesthq.github.io/chosen/options.html [^]

Changes to be done
<script>
/* Chosen Config */
jQuery( document ).ready(function() {
jQuery(".chosen-select").chosen({ width: "85%" , allow_single_deselect: true, search_contains: true});
jQuery('select[data-cfield="list"]').chosen({ width: "85%" , allow_single_deselect: true, search_contains: true});
});
</script>

(0029100)
fman (administrator)
2019-08-14 16:31

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/753aa70d4d1988c442218f22f949480b4b241a43 [^]

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/751a007d98becdaaedff226d929cef30b1ce2fc5 [^]

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/c4ae95ddf8cfa5b5319b6dd48dd4f2c922921b68 [^]

- Issue History
Date Modified Username Field Change
2019-08-12 13:27 EDT New Issue
2019-08-13 09:32 fman Note Added: 0029080
2019-08-13 09:40 fman Note Added: 0029081
2019-08-13 09:40 fman Note Edited: 0029081 View Revisions
2019-08-13 09:40 fman Assigned To => fman
2019-08-13 09:40 fman Status new => feedback
2019-08-13 09:43 fman Note Added: 0029082
2019-08-13 13:10 EDT File Added: unnamed.png
2019-08-13 13:11 EDT Note Added: 0029084
2019-08-13 13:11 EDT Status feedback => assigned
2019-08-13 17:08 fman Note Added: 0029087
2019-08-13 19:35 fman Note Added: 0029090
2019-08-13 19:35 fman QA Team - Task Workflow Status => TBD
2019-08-13 19:35 fman Note Added: 0029091
2019-08-13 19:35 fman Status assigned => closed
2019-08-13 19:35 fman Resolution open => not fixable
2019-08-14 07:40 EDT Note Added: 0029093
2019-08-14 07:40 EDT Status closed => assigned
2019-08-14 07:40 EDT Resolution not fixable => reopened
2019-08-14 14:59 fman Note Added: 0029095
2019-08-14 15:01 fman Summary Test Suite Filter malfunction with parentheses => Test Specification - Filter by Keyword - malfunction with parentheses
2019-08-14 15:15 fman Note Edited: 0029095 View Revisions
2019-08-14 15:16 fman File Added: Screen Shot 2019-08-13 at 21.53.33.png
2019-08-14 15:16 fman File Deleted: Screen Shot 2019-08-13 at 21.53.33.png
2019-08-14 15:16 fman File Added: Screen Shot 2019-08-14 at 17.08.55.png
2019-08-14 15:16 fman File Added: Screen Shot 2019-08-14 at 17.09.17.png
2019-08-14 15:16 fman File Added: Screen Shot 2019-08-14 at 17.09.37.png
2019-08-14 15:17 fman File Added: Screen Shot 2019-08-14 at 17.09.50.png
2019-08-14 15:18 fman Note Edited: 0029095 View Revisions
2019-08-14 15:25 fman Note Added: 0029097
2019-08-14 15:26 EDT Note Added: 0029098
2019-08-14 16:02 EDT Note Edited: 0029098 View Revisions
2019-08-14 16:21 fman Note Added: 0029099
2019-08-14 16:22 fman Note Edited: 0029099 View Revisions
2019-08-14 16:31 fman Note Added: 0029100
2019-08-14 16:32 fman Fixed in Version => 1.9.20 Raijing DEV
2019-08-14 16:32 fman Status assigned => resolved
2019-08-14 16:32 fman Resolution reopened => fixed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker