Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008721TestLinkAPI - XMLRPCpublic2019-07-10 07:232019-09-16 09:00
Reporterheju 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0008721: problems with XMLRPC: getTestCaseAttachments in 1.9.20
DescriptionDear TestLink Team,

with 1.9.20 the getTestCaseAttachments of the Python XMLRPC client is no longer working (https://pypi.org/project/TestLink-API-Python-client/ [^])

An exception is thrown: "ExpatError: junk after document element: line 1, column 91"

The parser seems to have a problem with the received content. The function works with TL 1.9.17

Could you please check if there was a change / is an error on TestLink side for this function, that would be very helpful.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0028999)
fman (administrator)
2019-07-10 20:19

We test the API only using the PHP clients that are provided with any TestLink installation.
If you are able to reproduce the issue using the PHP client and you provide very detailed steps to reproduce then some action can be taken.

Please do some search regarding this topic in this site, may be there is some related isssue
(0029056)
fman (administrator)
2019-07-27 09:29

no more user feedback
(0029159)
heju (reporter)
2019-09-16 09:00

Sorry, I did not find time to investigate using another client up to now.

In case someone faces similar problems: I just wanted to report, that after updating TL to the latest dev version from git

b5b15a248868045eb2560feb2b15ef6ac503b590

AND

using the latest python client TestLink-API-Python-client 0.8.1

the problem is gone.

Thank you!

- Issue History
Date Modified Username Field Change
2019-07-10 07:23 heju New Issue
2019-07-10 20:19 fman Note Added: 0028999
2019-07-27 09:29 fman QA Team - Task Workflow Status => TBD
2019-07-27 09:29 fman Note Added: 0029056
2019-07-27 09:29 fman Status new => closed
2019-07-27 09:29 fman Assigned To => fman
2019-07-27 09:29 fman Resolution open => unable to reproduce
2019-09-16 09:00 heju Note Added: 0029159
2019-09-16 09:00 heju Status closed => assigned
2019-09-16 09:00 heju Resolution unable to reproduce => reopened



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker