Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008706TestLinkTest Plan - Add/Remove Test Casespublic2019-06-24 09:232019-06-26 07:03
Reporterjinho84shin 
Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformLINUXOSubuntu OS Version18.04.01
Product Version1.9.19 (2019 Q1) 
Fixed in Version 
Summary0008706: On the testlink version V1.9.19, testcase adding process take a long time before(V1.9.14)
Descriptionhi there.
i have a question about adding testcases.

Testlink process is taking a long time when i adding testcases in the testcase add/remove menu.

Recently i updated testlink version upgrade from V1.9.14 to V1.9.19.

Testlink V1.9.14 does not taking a long time to add testcases on the same environment.(totally same environment(OS/PHP/MYSQL/DB))


So i have checked the menu and i found some different menu.
(attached the png)

In the Setting Menu, "Tests Grouped By" option is added at testlink V1.9.19.

Can it makes testcases add process slower then before?

If it is make adding porcee slower then before. can i disable that menu?
Steps To Reproduce1. Move to Add/Remove Test Cases.
2. Select "Show Full(on right pane)"
3. Select "adding" on the right screen
4. Select "Add/Remove Selected"
5. Waiting to complete add/remote testcases.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql V14.14
BrowserChrome
PHP VersionPHP V7.2.19
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon testlink diff.png [^] (53,266 bytes) 2019-06-24 09:23

- Relationships

-  Notes
(0028961)
fman (administrator)
2019-06-24 22:01

in any upgrading is always suggested to do an upgrade to next version and do a minor test before continue to another version

with the indications you are providing unfortunately there is no way to provide any help.
The new option can not affect you if you do not use it.

try to ask on forum.testlink.org to have some user help
(0028964)
jinho84shin (reporter)
2019-06-25 00:50

First of all, thanks to your comment fman.(my english writing skill is awful, i'm not used to it)

As your Comment, i had already check thist procedure, on the other version.

And i got a result like below

1. V1.9.14/V1.9.15/V1.9.16 : No Problem
2. V1.9.17/V1.9.18/V1.9.19 : slower then before

Do you have any recommend that i have to check?
(0028965)
fman (administrator)
2019-06-25 08:19

Can you try with the OLD option I.e. without using the requirements?

regards
(0028966)
jinho84shin (reporter)
2019-06-25 09:22

i have been using the testlink without requirement.
(When i create the test project, i had uncheck the requirement option)

thanks to your reply. as your recommend i have to try to ask on forum.testlink.org.

If i got the solution, i add the note on this issue.
(0028968)
fman (administrator)
2019-06-26 07:03

OK, nobody else have reported it, it's very strange

any hint on SQL logs ? slow queries?
regards

- Issue History
Date Modified Username Field Change
2019-06-24 09:23 jinho84shin New Issue
2019-06-24 09:23 jinho84shin File Added: testlink diff.png
2019-06-24 22:01 fman Note Added: 0028961
2019-06-25 00:50 jinho84shin Note Added: 0028964
2019-06-25 08:19 fman Note Added: 0028965
2019-06-25 09:22 jinho84shin Note Added: 0028966
2019-06-26 07:03 fman Note Added: 0028968



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker