Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008690TestLinkRequirement to Test Case Assignmentpublic2019-06-12 15:422019-06-16 09:01
Reporterheju 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0008690: Assigned Requirements not shown in Assign Requirements to Test Case Window
DescriptionDear TestLink Team,

with tl 1.9.20, the "Assigned Requirements" in "Assign Requirements to Test Case Window" does not show any content, even if Requirements are assigned.

The display in the requirement and the testcase shows the correct assignments. Only in this pop-up window the Assigned requriements are empty. (the available requirements are shown normally)

This happens for a testproject migrated from 1.9.17/18/19 to 1.9.20. With a New test project the display works fine.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0028932)
heju (reporter)
2019-06-12 15:52

Update: Deleting all test case links to a specific requirement and relinking brings back the correct display.

Hope there is another option than recreating all links manually...
(0028935)
fman (administrator)
2019-06-12 16:27

all your issues are related to a bad migration => no way to help you
(0028937)
fman (administrator)
2019-06-13 09:26

Nobody got hurt by your tickets, it's ok that you report it and is of great help

I'm not sure migration has been done in the right way, but if you can not provide the original db I can do nothing
(0028950)
heju (reporter)
2019-06-16 08:48

Did some more experiments on this one.

It's not related to migration.
The point is: In the "assigned requirements" section only the assigned requirements of the currently (drop down select above) selected req spec are shown. Therefore if there are a lot of req specs chances are high, that the "assigned" section is empty.

Not sure if this was always the case and/or is the intended behavior.
I thought for previous TL versions, the "assigned requirements" section showed all assigned reqs, independent of the selected req spec doc.

Best regards
(0028951)
heju (reporter)
2019-06-16 09:00
edited on: 2019-06-16 09:01

After investigation found out the root cause (see post above). Needs clarification if the current behavior is the intended one.


- Issue History
Date Modified Username Field Change
2019-06-12 15:42 heju New Issue
2019-06-12 15:52 heju Note Added: 0028932
2019-06-12 16:27 fman Note Added: 0028935
2019-06-12 16:27 fman QA Team - Task Workflow Status => TBD
2019-06-12 16:27 fman Status new => resolved
2019-06-12 16:27 fman Resolution open => unable to reproduce
2019-06-12 16:27 fman Assigned To => fman
2019-06-13 09:26 fman Note Added: 0028937
2019-06-16 08:48 heju Note Added: 0028950
2019-06-16 09:00 heju Note Added: 0028951
2019-06-16 09:00 heju Status resolved => assigned
2019-06-16 09:00 heju Resolution unable to reproduce => reopened
2019-06-16 09:01 heju Note Edited: 0028951 View Revisions
2019-06-16 09:01 heju Note Edited: 0028951 View Revisions



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker