Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008647TestLinkKeywordspublic2019-04-24 12:472019-05-03 17:06
Reportermshishodia 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version1.9.19 (2019 Q1) 
Fixed in Version 
Summary0008647: Keyword dispalyed as none in test cases after upgrading 1.9.19
DescriptionUpgrade testlink 1.9.17 > testlink 1.9.18
Upgrade testlink 1.9.18 > testlink 1.9.19

Now when seeing existing test cases, then keyword displayed as none.
Now when I'm looking in testlink DB.
In Keyword Table tcversion_id = 0 instead of value's


TagsNo tags attached.
Database (MySQL,Postgres,etc)MYSQL 8.0
BrowserChrome, ff
PHP Version7.2
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesjpg file icon Testlink_Keywor_Issue .jpg [^] (188,529 bytes) 2019-04-24 12:47

- Relationships
related to 0008639closedfman Keyword missing in Testlink 1.9.18 and 1.9.19 

-  Notes
(0028765)
mshishodia (reporter)
2019-04-24 12:51

In the Keyword table, tcversion_id belong to Testcase_id or testcase version ?

tcversion_id store in which table
(0028766)
fman (administrator)
2019-04-24 15:22

tcversion_id means tcversion ID

tcversion_id store in which table? tcversions table, id field

IMHO your upgrade has not be done completely
(0028768)
mshishodia (reporter)
2019-04-25 05:35

tell me now what I do
(0028769)
fman (administrator)
2019-04-25 08:20

Hi
dear user, it will be great if you can understood that a minimul of politeness is needed whe asking for help:

Then => tell me now what I do => NO good
Would you mind to provide me some intructions? => a bit better

I can not provide step by steps instructions, because IMHO all the instructions are present in the README present with each distribution.

In addition your way to provide details is such that you never provide detailed steps you have done.

IMHO you need to proceed first to 1.9.18, checking the result of the different sql script you have runned.

For my point of view till now I saw no evidence of issue => ticket will be closed
(0028774)
mshishodia (reporter)
2019-04-25 09:07

I upgrade Testlink 1.9.17 > 1.9.18
and

Execute `install/sql/alter_tables/1.9.18/<your_db>/DB.1.9.17/step1/db_schema_update.sql`
  b. Execute (IF EXISTS) `install/sql/alter_tables/1.9.18/<your_db>/DB.1.9.17/stepZ/z_final_step.sql`
Then I upgrade Testlink-1.9.18 > 1.9.19
and
Execute `install/sql/alter_tables/1.9.19/<your_db>/DB.1.9.18/step1/db_schema_update.sql`
  b. Execute (IF EXISTS) `install/sql/alter_tables/1.9.19/<your_db>/DB.1.9.18/stepZ/z_final_step.sql`

After upgrading I view test cases under test specification
Keyword displayed as NONE

Then I looking to DB and found that tcversion_id = 0 for all test cases in testcase_keyword table.

Can you please suggest how can I get my tcversion_id in testcase_keyword
(0028777)
fman (administrator)
2019-04-25 10:29
edited on: 2019-04-25 10:30

There was a mistake on the README.MD, finally a mistake but not so difficult to solve if you read with attention the file
I was able to find it now after all this ping pong because finally, you have provided the details requested.

In addition if you have proceed as requested i.e. FIRST go to 1.9.18 and see if things worked we have saved lot of time.

Next time you ask for help it will be better that you follow the instructions provided.

The right way to upgrade to 1.9.18 from 1.9.17 is


13. Upgrade from 1.9.17 to 1.9.18

WARNING: if you are using a table prefix replace `prefix` with your prefix

  a. Execute `install/sql/alter_tables/1.9.18/<your_db>/DB.1.9.18/step1/db_schema_update.sql`
  b. Execute (IF EXISTS) `install/sql/alter_tables/1.9.18/<your_db>/DB.1.9.18/stepZ/z_final_step.sql`


if you open the sql files (a thing that is not going to hurt) you will find the sql that update the new fields

ONly after you have moved th 1.9.18 and you see that keywords are OK, then you can move to 1.9.19

Same minor error on 1.19.18 to 1.19.19


 a. Execute `install/sql/alter_tables/1.9.19/<your_db>/DB.1.9.19/step1/db_schema_update.sql`
  b. Execute (IF EXISTS) `install/sql/alter_tables/1.9.19/<your_db>/DB.1.9.19/stepZ/z_final_step.sql`

(0028778)
fman (administrator)
2019-04-25 10:32

why you have opened a new ticket leaving 0008639 opened?
(0028799)
fman (administrator)
2019-04-29 10:27

would you mind to provide feedback?
(0028800)
mshishodia (reporter)
2019-04-29 10:30

It's not work, reason I made changes in DB, so table already there in DB .
(0028801)
fman (administrator)
2019-04-29 10:35

then you will need to restart from a backup

- Issue History
Date Modified Username Field Change
2019-04-24 12:47 mshishodia New Issue
2019-04-24 12:47 mshishodia File Added: Testlink_Keywor_Issue .jpg
2019-04-24 12:51 mshishodia Note Added: 0028765
2019-04-24 15:22 fman Note Added: 0028766
2019-04-25 05:35 mshishodia Note Added: 0028768
2019-04-25 08:20 fman Note Added: 0028769
2019-04-25 08:21 fman QA Team - Task Workflow Status => TBD
2019-04-25 08:21 fman Status new => closed
2019-04-25 08:21 fman Assigned To => fman
2019-04-25 08:21 fman Resolution open => unable to reproduce
2019-04-25 09:07 mshishodia Note Added: 0028774
2019-04-25 09:07 mshishodia Status closed => assigned
2019-04-25 09:07 mshishodia Resolution unable to reproduce => reopened
2019-04-25 10:29 fman Note Added: 0028777
2019-04-25 10:30 fman Note Edited: 0028777 View Revisions
2019-04-25 10:30 fman Note View State: 0028777: public
2019-04-25 10:31 fman Relationship added related to 0008639
2019-04-25 10:32 fman Note Added: 0028778
2019-04-26 17:25 fman Status assigned => feedback
2019-04-29 10:27 fman Note Added: 0028799
2019-04-29 10:30 mshishodia Note Added: 0028800
2019-04-29 10:30 mshishodia Status feedback => assigned
2019-04-29 10:35 fman Note Added: 0028801
2019-05-03 17:06 fman Status assigned => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker