Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008622TestLinkRequirement Managementpublic2019-04-04 19:502019-05-13 16:10
Reporteracoloma 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformWindowsOSWindows Server 2012 R2OS Version6.3.9600
Product Version1.9.18 (2018 Q3) 
Fixed in Version1.9.19 (2019 Q1) 
Summary0008622: Requirement Specifications Filtering not working
DescriptionRequirement Specifications Filtering not working.
It always display what is available or what is already there.
Steps To ReproduceSteps to reproduce
1. Requirement Specification
2. Set status to anything other than Any
3. Click Apply
4. Result is not updated, always display what's in there already, see attachment.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE, Edge, Firefox & Chrome
PHP Version7.1.2
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon RequirementSpecifications.png [^] (66,416 bytes) 2019-04-04 21:15


png file icon TestlinkRequirementIssue.png [^] (177,105 bytes) 2019-04-16 16:43


png file icon TestlinkRequirementStatusIssues.png [^] (135,927 bytes) 2019-05-12 23:09


png file icon TestlinkRequirementStatusIssues-1.png [^] (86,504 bytes) 2019-05-12 23:13

- Relationships

-  Notes
(0028676)
acoloma (reporter)
2019-04-04 21:33
edited on: 2019-04-04 21:34

Correction, the filters that does not work are "Finish", "Valid" or "Review".
There are data that are returned with status = "Valid" even if the status filter is set to "Finish" or "Review"

(0028716)
fman (administrator)
2019-04-13 16:31
edited on: 2019-04-13 16:32

tested on 1.9.19.01
requirement has just one version
works ok

requirement has two versions
works ok

(0028728)
acoloma (reporter)
2019-04-16 16:42

Thanks fman!
It's still an issue on my Teslink instance. Not sure if the problem is on these two requirements.
(0028817)
acoloma (reporter)
2019-05-08 16:00

It's still an issue on my Teslink instance even after I upgraded Teslink to the latest verision . Not sure if the problem is on these two requirements.

Can you please help.
Maybe you can provide me a mysql command I can use to check the data in the database and compare with other requirements.

Thanks!
(0028821)
acoloma (reporter)
2019-05-12 23:09
edited on: 2019-05-12 23:14

I just noticed that the Requirements Status were both already "Finish" before then it was changed to "Review".

Is this the reason why both Requirements were displayed as a result when we query Requirements with status "Finish"?

Using status = "Review" as well displays both requirements.

Please find attached screenshot. TestlinkRequirementStatusIssues.png

Do you mind providing me the DB query/statements to produce these results?

Thanks!

(0028823)
fman (administrator)
2019-05-13 16:10

Hi
thanks for the info.
Unfortunately is not a matter of copy & paste to provide you the SQL.
The trace of the whole function call change is needed and right now unfortunately I don't have enough free time for this

- Issue History
Date Modified Username Field Change
2019-04-04 19:50 acoloma New Issue
2019-04-04 21:15 acoloma File Added: RequirementSpecifications.png
2019-04-04 21:33 acoloma Note Added: 0028676
2019-04-04 21:34 acoloma Note Edited: 0028676 View Revisions
2019-04-13 16:31 fman Note Added: 0028716
2019-04-13 16:32 fman Note Edited: 0028716 View Revisions
2019-04-13 16:32 fman QA Team - Task Workflow Status => TBD
2019-04-13 16:32 fman Status new => resolved
2019-04-13 16:32 fman Fixed in Version => 1.9.19 (2019 Q1)
2019-04-13 16:32 fman Resolution open => fixed
2019-04-13 16:32 fman Assigned To => fman
2019-04-16 16:42 acoloma Note Added: 0028728
2019-04-16 16:43 acoloma File Added: TestlinkRequirementIssue.png
2019-05-08 16:00 acoloma Note Added: 0028817
2019-05-08 16:00 acoloma Status resolved => assigned
2019-05-08 16:00 acoloma Resolution fixed => reopened
2019-05-12 23:09 acoloma Note Added: 0028821
2019-05-12 23:09 acoloma File Added: TestlinkRequirementStatusIssues.png
2019-05-12 23:10 acoloma Note Edited: 0028821 View Revisions
2019-05-12 23:13 acoloma File Added: TestlinkRequirementStatusIssues-1.png
2019-05-12 23:14 acoloma Note Edited: 0028821 View Revisions
2019-05-13 16:10 fman Note Added: 0028823



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker