Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008596TestLinkDatabase MySQLpublic2019-03-13 13:432019-03-13 15:22
Reportermshishodia 
Assigned Tofman 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version1.9.19 (2019 Q1) 
Fixed in Version 
Summary0008596: Fatl eroor while update PHP and user logged in Testlink-1.9.19
Description fatal error display "Warning: strftime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in C:\Apache24\htdocs\testlink-1.9.19\config.inc.php on line 1901

Fatal error: Call to undefined function mysql_connect() in C:\Apache24\htdocs\testlink-1.9.19\vendor\adodb\adodb-php\drivers\adodb-mysql.inc.php on line 461"
Steps To ReproduceSteps:
1. Download PHP 5.6
2. Made changes config file for PHP 5.6
3. Made changes in Testlink config file and run query in DB
4. Now upgrade DB version.
5. Launch Testlink
6. Login with existing user

Result : fatal error display "Warning: strftime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in C:\Apache24\htdocs\testlink-1.9.19\config.inc.php on line 1901

Fatal error: Call to undefined function mysql_connect() in C:\Apache24\htdocs\testlink-1.9.19\vendor\adodb\adodb-php\drivers\adodb-mysql.inc.php on line 461"
Additional InformationPHP 5.6
 MYSQL 5.6
Testlink-1.9.19
TagsNo tags attached.
Database (MySQL,Postgres,etc)msql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0028595)
fman (administrator)
2019-03-13 14:46

message is clear => you have a PHP config issue
(0028596)
mshishodia (reporter)
2019-03-13 14:51

Can you help me in php config setting
(0028597)
mshishodia (reporter)
2019-03-13 14:51

Do I need to upgrade MySQL server or php version
(0028598)
fman (administrator)
2019-03-13 15:22

I can not provide this kind of support because has nothing to do with the product.
You have to use the PHP documentation + stackoverflow

- Issue History
Date Modified Username Field Change
2019-03-13 13:43 mshishodia New Issue
2019-03-13 14:46 fman Note Added: 0028595
2019-03-13 14:46 fman QA Team - Task Workflow Status => TBD
2019-03-13 14:46 fman Status new => resolved
2019-03-13 14:46 fman Resolution open => no change required
2019-03-13 14:46 fman Assigned To => fman
2019-03-13 14:51 mshishodia Note Added: 0028596
2019-03-13 14:51 mshishodia Note Added: 0028597
2019-03-13 15:22 fman Note Added: 0028598
2019-03-13 15:22 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker