Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008531TestLinkTest Spec. - Test Case relationspublic2019-01-09 18:032019-02-04 16:37
Reporternoliveira 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.18 (2018 Q3) 
Fixed in Version 
Summary0008531: Error while add a relation with another test case
DescriptionError while add a relation with another test case
Steps To Reproduce1. Open a test case
2. Insert an ID of another test case and click add
3. Show this error:

#0 database->exec_query( / Class:testcase - Method: addRelation / INSERT INTO testcase_relations (source_id, destination_id, relation_type, author_id, creation_ts) values (1495541,1460168, 3, 53, '2019-01-09 14:55:35')) called at [/var/www/testlink/lib/functions/testcase.class.php:6257]
#1 testcase->addRelation(1495540, 1460167, 3, 53) called at [/var/www/testlink/lib/testcases/testcaseCommands.class.php:1124]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.6.38
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0028413)
fman (administrator)
2019-01-09 19:27

1. DBMS type & version are needed
2. Please try the sql on a sql client to get more info
3. Please get latest code from github, do fresh install, retest & provide feedback
(0028415)
noliveira (reporter)
2019-01-09 21:43

I receive an error at the sql client:

mysql> INSERT INTO testcase_relations (source_id, destination_id, relation_type, author_id, creation_ts) values (1495541,1460168, 3, 53, '2019-01-09 14:55:35');
ERROR 1364 (HY000): Field 'tcase_source_id' doesn't have a default value

Can you help with this error?
(0028416)
fman (administrator)
2019-01-10 07:30

Hi
please

1. DBMS type & version are needed
3. Please get latest code from github, do fresh install, retest & provide feedback

this seems a bad migration
(0028443)
fman (administrator)
2019-01-19 15:04

no more user feedback
(0028504)
noliveira (reporter)
2019-02-04 13:09

Hello, sorry for the delay in my response.

1. DBMS is MySQL 5.6.41
3. This will not solve our problem. The migration was made by Testlink scripts, like I said in previous issues

Are you saying to fresh install and import our DB?
(0028506)
noliveira (reporter)
2019-02-04 15:14

I did a fresh install with 1.9.20. Execute the migration script from 1.9.18 to 1.9.19

The issue stills present
(0028507)
fman (administrator)
2019-02-04 15:17

go to the db and remove the offending column from testcase_relations table.
(0028508)
noliveira (reporter)
2019-02-04 15:20

Ok. Now I receive another error:

mysql> INSERT INTO testcase_relations (source_id, destination_id, relation_type, author_id, creation_ts) values (1495541,1460168, 3, 53, '2019-01-09 14:55:35');
ERROR 1364 (HY000): Field 'tcase_destination_id' doesn't have a default value
(0028509)
fman (administrator)
2019-02-04 16:37

You have to give a look to this table structure with a FRESH installation and remove additonal columns.

closing

- Issue History
Date Modified Username Field Change
2019-01-09 18:03 noliveira New Issue
2019-01-09 19:27 fman Note Added: 0028413
2019-01-09 19:27 fman Status new => feedback
2019-01-09 21:43 noliveira Note Added: 0028415
2019-01-09 21:43 noliveira Status feedback => new
2019-01-10 07:30 fman Note Added: 0028416
2019-01-19 15:04 fman QA Team - Task Workflow Status => TBD
2019-01-19 15:04 fman Note Added: 0028443
2019-01-19 15:04 fman Status new => resolved
2019-01-19 15:04 fman Resolution open => unable to reproduce
2019-01-19 15:04 fman Assigned To => fman
2019-02-04 13:09 noliveira Note Added: 0028504
2019-02-04 15:14 noliveira Note Added: 0028506
2019-02-04 15:14 noliveira Status resolved => assigned
2019-02-04 15:14 noliveira Resolution unable to reproduce => reopened
2019-02-04 15:17 fman Note Added: 0028507
2019-02-04 15:17 fman Status assigned => feedback
2019-02-04 15:20 noliveira Note Added: 0028508
2019-02-04 15:20 noliveira Status feedback => assigned
2019-02-04 16:37 fman Note Added: 0028509
2019-02-04 16:37 fman Status assigned => closed
2019-02-04 16:37 fman Resolution reopened => fixed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker