Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008489TestLinkRequirement Version Comparepublic2018-11-26 11:062019-04-02 20:41
Reporteracoloma 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWindows Server 2012 R2 DatacenteOS Version6.3.9600
Product Version1.9.18 (2018 Q3) 
Fixed in Version1.9.19 (2019 Q1) 
Summary0008489: Unable to load template file displayReqCoverageRO.inc.tpl
DescriptionTestlink display this error when viewing history

Fatal error: Uncaught SmartyException: Unable to load template file './displayReqCoverageRO.inc.tpl'

Steps To Reproduce1. Click Requirements button [Navigator - Requirement Specifications]
2. Pick a Requirement [Requirement : Activity History - General functionality]
3. Click on Actions
4. Click on View History [Requirement versions compare page]
Additional Informationhttps://testlinksandbox.ramsoft.com/lib/requirements/reqViewRevision.php?showReqSpecTitle=1&item_id=511215 [^]

Fatal error: Uncaught SmartyException: Unable to load template file './displayReqCoverageRO.inc.tpl' in './reqViewRevisionViewer.tpl' in C:\xampp\htdocs\testlink\third_party\smarty3\libs\sysplugins\smarty_internal_templatebase.php:127 Stack trace: #0 C:\xampp\htdocs\testlink\third_party\smarty3\libs\sysplugins\smarty_internal_template.php(286): Smarty_Internal_TemplateBase->fetch(Object(Smarty_Internal_Template), NULL, NULL, NULL, false, false, true) #1 C:\xampp\htdocs\testlink\gui\templates_c\54a8f022ae623852e0308f7db4702a7ad9d0b9d6.file.reqViewRevisionViewer.tpl.php(140): Smarty_Internal_Template->getSubTemplate('./displayReqCov...', NULL, NULL, NULL, NULL, Array, 0) 0000002 C:\xampp\htdocs\testlink\third_party\smarty3\libs\sysplugins\smarty_internal_templatebase.php(180): content_5bfba34d36a953_89275825(Object(Smarty_Internal_Template)) 0000003 C:\xampp\htdocs\testlink\third_party\smarty3\libs\sysplugins\smarty_internal_template.php(286): Smarty_Internal_TemplateBase->fetch(Object(Smarty_Internal_Template), NULL, NULL, NULL, fal in C:\xampp\htdocs\testlink\third_party\smarty3\libs\sysplugins\smarty_internal_templatebase.php on line 127
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserEdge, Chrome, IE, Firefox
PHP Version7.1.2
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon ViewHistory.png [^] (33,022 bytes) 2018-11-26 11:06

- Relationships

-  Notes
(0028378)
fman (administrator)
2018-12-23 09:32

tested on latest code from github, unable to reproduce
(0028389)
acoloma (reporter)
2018-12-26 01:16

Hi fman,

I downloaded the latest code, or maybe not, and applied it to my sandbox but I get this error when I try to login.

Fatal error: Class 'Smarty' not found in C:\xampp\htdocs\testlink\lib\functions\tlsmarty.inc.php on line 83


Is this the link to the latest code or the 1.9.19 release?
https://github.com/TestLinkOpenSourceTRMS/testlink-code [^]
(0028390)
fman (administrator)
2018-12-26 10:29

The branch to use is testlink_1_9.
When you access github via web this is the default branch, then if you use the red button : Clone or Download you will get the right code.

Other option is to get same code using wget, as explained in

http://mantis.testlink.org/view.php?id=8397 [^]

Other option is to clone the repository using git.
(0028394)
acoloma (reporter)
2018-12-28 15:22

I downloaded and applied the latest code but I still get this error when viewing the history of any requirement.

https://testlinksandbox.ramsoft.com/lib/requirements/reqViewRevision.php?showReqSpecTitle=1&item_id=511618 [^]
-------------------------------------------------------------------------------
Fatal error: Uncaught --> Smarty: Unable to load template 'file:./displayReqCoverageRO.inc.tpl' in './reqViewRevisionViewer.tpl' <-- thrown in C:\xampp\htdocs\testlink\vendor\smarty\smarty\libs\sysplugins\smarty_internal_template.php on line 195


And I cannot find the "displayReqCoverageRO.inc.tpl" template file anywhere.
(0028396)
fman (administrator)
2018-12-29 08:45

I'm going to retest, and provide feedback
(0028397)
fman (administrator)
2018-12-29 08:52

I'm sorry, file was missing on latest version but present on my dev tree (my fault).
Just commited
(0028398)
fman (administrator)
2018-12-29 08:53

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/50a8be65a9f632c1f2aa806ac629359589d23239 [^]
(0028400)
acoloma (reporter)
2018-12-31 12:23

Thanks a lot fman!
Functionality works well now!

- Issue History
Date Modified Username Field Change
2018-11-26 11:06 acoloma New Issue
2018-11-26 11:06 acoloma File Added: ViewHistory.png
2018-12-23 09:32 fman Note Added: 0028378
2018-12-23 09:33 fman QA Team - Task Workflow Status => READY FOR TESTING
2018-12-23 09:33 fman Status new => resolved
2018-12-23 09:33 fman Fixed in Version => 1.9.19 (2019 Q1)
2018-12-23 09:33 fman Resolution open => fixed
2018-12-23 09:33 fman Assigned To => fman
2018-12-26 01:16 acoloma Note Added: 0028389
2018-12-26 10:29 fman Note Added: 0028390
2018-12-28 15:22 acoloma Note Added: 0028394
2018-12-29 08:45 fman Note Added: 0028396
2018-12-29 08:52 fman Note Added: 0028397
2018-12-29 08:53 fman Note Added: 0028398
2018-12-31 12:23 acoloma Note Added: 0028400
2019-04-02 20:41 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker