Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008429TestLinkTest Specification - Move/Copy Test Casespublic2018-10-25 08:592018-11-06 18:36
Reporterandreea.biosan 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.19 (2019 Q1) 
Summary0008429: Copy the Test case through Move/Copy option will not copy the Requirements nor the Keywords
DescriptionCopying a Test Case from it's own dialog, through Move/ Copy option, will not copy the requirements nor the keywords.
Steps To Reproduce1. Go to ASCT-329: Monarch ID
2. Press on "Actions"
3. From the "Test Case Operations" choose option "Move/ Copy"
4. On the "Move/ Copy Test Case" dialog check both check boxes: "Copy Keyword Assignments" and "Copy Requirement Assignments"
5. On the "Choose Test Suite" choose Suite "DemoTest Module" -> "Demo Test Base"
5. New test Case name : "Monarch ID - Copy"

Go to Sub-Suite "Demo Test Base" and open the newly copied Test Case. The requirements and the keywords are missing
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesdocx file icon Move Copy process.docx [^] (121,271 bytes) 2018-10-25 08:59

- Relationships

-  Notes
(0028092)
fman (administrator)
2018-10-25 15:52

will check
(0028095)
fman (administrator)
2018-10-25 19:15

issue found when test case has steps, due to a variable overwrite
(0028172)
andreea.biosan (reporter)
2018-11-06 10:49

Passed verification: Keywords, Requirements, Attachments are copied.

- Issue History
Date Modified Username Field Change
2018-10-25 08:59 andreea.biosan New Issue
2018-10-25 08:59 andreea.biosan File Added: Move Copy process.docx
2018-10-25 15:52 fman Note Added: 0028092
2018-10-25 15:52 fman Assigned To => fman
2018-10-25 15:52 fman Status new => assigned
2018-10-25 19:15 fman Note Added: 0028095
2018-10-25 19:16 fman Status assigned => feedback
2018-10-25 19:18 fman QA Team - Task Workflow Status => TBD
2018-10-25 19:18 fman Severity minor => major
2018-10-25 19:18 fman View Status private => public
2018-11-01 19:05 fman Status feedback => resolved
2018-11-01 19:05 fman Fixed in Version => 1.9.19 (2019 Q1)
2018-11-01 19:05 fman Resolution open => fixed
2018-11-06 10:49 andreea.biosan Note Added: 0028172
2018-11-06 18:36 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2018-11-06 18:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker