Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008422TestLinkTest Plan - Add/Remove Test Casespublic2018-10-22 12:412018-11-06 18:36
Reporterandreea.biosan 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.19 (2019 Q1) 
Summary0008422: "Add to Test Plans" it's missing at the Test Case level
Description"Add to Test Plans" option at the Test Case level it's missing from Testlink
Steps To Reproduce1. Go to ASCT-1225 : Test field "Add to Test Plans"
2. Press on button "Actions"

Actual result: Button "Add to Test Plans" it's completely missing
Expected result: Button "Add to Test Plans" should be available

For more details please find attached document.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon Add to test plans.jpg [^] (66,204 bytes) 2018-10-22 12:41

- Relationships
child of 0008397assignedfman Availables hot-fixes for 1.9.18 & How To get full fixed package from GitHub 

-  Notes
(0028057)
hughkay (reporter)
2018-10-22 13:35
edited on: 2018-10-22 13:36

Bug confirmed on my side, as well.

@fman: As far as I can see the bug is located in lib/functions/testcase.class.php, lines 6857 et seq.:

// Add To Testplan button will be disabled if the testcase doesn't belong to the current selected testproject
$goo->can_do->add2tplan = 'no';
if($idCard->tproject_id == $goo->tproject_id) {
      $goo->can_do->add2tplan = ($goo->can_do->add2tplan == 'yes') ? $grantsObj->testplan_planning : 'no';
}


The condition within the allocation of "$goo->can_do->add2tplan" will always evaluate to "False" because "$goo->can_do->add2tplan" was explicitly set to 'no' two lines earlier.

Suggestion:
Change the allocation line (6860) to the following: "$goo->can_do->add2tplan = ($grantsObj->testplan_planning == 'yes') ? 'yes' : 'no';"

At least, this works for me.

(0028060)
fman (administrator)
2018-10-22 14:16

@hunghkay: thanks a lot.
I'm going to check
(0028066)
fman (administrator)
2018-10-22 17:36

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/2f9939ac0d92557a1045f46f9e5a3113fd064d34 [^]
(0028173)
andreea.biosan (reporter)
2018-11-06 10:52

Passed verification

- Issue History
Date Modified Username Field Change
2018-10-22 12:41 andreea.biosan New Issue
2018-10-22 12:41 andreea.biosan File Added: Add to test plans.jpg
2018-10-22 13:35 hughkay Note Added: 0028057
2018-10-22 13:36 hughkay Note Edited: 0028057 View Revisions
2018-10-22 14:16 fman Note Added: 0028060
2018-10-22 14:18 fman QA Team - Task Workflow Status => TBD
2018-10-22 14:18 fman Severity major => minor
2018-10-22 17:36 fman Note Added: 0028066
2018-10-22 17:36 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2018-10-22 17:36 fman Status new => resolved
2018-10-22 17:36 fman Fixed in Version => 1.9.19 (2019 Q1)
2018-10-22 17:36 fman Resolution open => fixed
2018-10-22 17:36 fman Assigned To => fman
2018-10-22 18:03 fman Relationship added child of 0008397
2018-11-06 10:52 andreea.biosan Note Added: 0028173
2018-11-06 18:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker