Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008385TestLinkBug Tracking System - JIRA Integrationpublic2018-09-25 09:332018-10-06 12:17
Reportercyuste 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.17 (2018 Q1) 
Fixed in Version1.9.18 (2018 Q3) 
Summary0008385: Cannot create a new bug in Jira from testlink: 500 error
DescriptionThe button to create a new issue doesn't work with a valid Jira connection. If I use the bottom checkbox to create the ticket it does work
Additional InformationIn apache log I can see the following:

PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function generateIssueText(), 3 passed in /var/www/testlink/lib/execute/bugAdd.php on line 26 and exactly 4 expected in /var/www/testlink/lib/functions/exec.inc.php:694

And indeed if I modify bugAdd.php and replace line 26 with the following:

$dummy = generateIssueText($db,$args,$its,$args->addLinkToTL);

It does work. There are a few other places where generateIssueText is only called with 3 parameters, I don't know if it shoud be modifed in all of them
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
child of 0008241closedfman Availables hot-fixes for 1.9.17 & How To get full fixed package from GitHub 

-  Notes
(0027881)
fman (administrator)
2018-09-25 10:30

get latest code from github, do fresh install, retest & provide feedback
(0027885)
cyuste (reporter)
2018-09-25 11:36

Downloaded last code from gihub:
git status
On branch testlink_1_9
Your branch is up to date with 'origin/testlink_1_9'.

nothing to commit, working tree clean

copied config.inc.php and config_db.inc.php to the new folder and tried again, the error can be reproduced
(0027886)
fman (administrator)
2018-09-25 12:08

Because PHP version has been not mentioned, I think issue is related to PHP 7.x that is more picky that 5.x

going to fix.

regards
(0027888)
cyuste (reporter)
2018-09-25 12:50

Yes, is php v7.2, sorry for that. It is an ubuntu machine created last week with the last versions from the official repos

Thanks
(0027890)
fman (administrator)
2018-09-25 15:29

going to fix changing function signature this way

FROM
function generateIssueText($dbHandler,$argsObj,$itsObj,$addLinkToTL)

TO
function generateIssueText($dbHandler,$argsObj,$itsObj,$addLinkToTL=false)
(0027891)
fman (administrator)
2018-09-25 15:31

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/8086879cbd46e25936f9c608c4250e06903ab99f [^]
(0027929)
fman (administrator)
2018-10-06 12:17

1.9.18 released

- Issue History
Date Modified Username Field Change
2018-09-25 09:33 cyuste New Issue
2018-09-25 10:30 fman Note Added: 0027881
2018-09-25 10:30 fman Assigned To => fman
2018-09-25 10:30 fman Status new => feedback
2018-09-25 11:36 cyuste Note Added: 0027885
2018-09-25 11:36 cyuste Status feedback => assigned
2018-09-25 12:08 fman Note Added: 0027886
2018-09-25 12:09 fman QA Team - Task Workflow Status => TBD
2018-09-25 12:50 cyuste Note Added: 0027888
2018-09-25 15:29 fman Note Added: 0027890
2018-09-25 15:31 fman Note Added: 0027891
2018-09-25 15:31 fman Status assigned => resolved
2018-09-25 15:31 fman Fixed in Version => 1.9.18 (2018 Q3)
2018-09-25 15:31 fman Resolution open => fixed
2018-09-25 15:31 fman Relationship added child of 0008241
2018-10-06 12:17 fman Note Added: 0027929
2018-10-06 12:17 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker