Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008334TestLinkReportspublic2018-07-17 04:202018-08-09 07:34
Reporterarun.singh 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionopen 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0008334: Reports around Test specification
DescriptionMost of the reports available are around test execution.

Do we have reports like below around test specification as well:
Based on Execution type (Need: This would give a clear idea on what percentage of automation has been achieved). Would be great to have the report created based on folder structure defined in test specification as that gives a capability to assess the same at module level as well.
Reference to additional reports would also help.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0027698)
fman (administrator)
2018-07-17 05:31

your requirement is not clear and too generic
you need to open ONE TICKET for each report
without more details, issue will be closed
(0027751)
fman (administrator)
2018-08-07 16:49

no more user feedback
(0027754)
arun.singh (reporter)
2018-08-08 04:04
edited on: 2018-08-08 04:06

I explicitly quoted an example as well to be specific and help in understanding the same.
Am providing further details on the same with another more simpler example, to help you understand as I assumed you being an SME on testlink would get it with the details provided.
1. Create a folder naming 'Login' in Test specification. This is meant to have all modules (e.g. Social, App, Web, Auto Login) for login functionality.
2. Create a Sub folder naming 'Social' under 'Login' folder in Test specification. This folder would have all the test cases for social login (e.g. facebook login, google login etc.)
3. Similarly add other sub-folders naming 'App login', 'web Login', 'Auto login' (for active sessions) and further add test cases to corresponding sub-folder.
4. Create a Plan with all Login cases (from root folder of 'Login') added to it.
5. Create a build and execute all cases to it.
6. Now in the "General test Plan Metrics" report. The count would be for complete root folder and one cannot check via report as to which of the 4 sub-modules have maximum failures and which one seems stable.

Hope it makes things clear.

(0027755)
fman (administrator)
2018-08-08 09:55

Things are a little bit clear, but step (6) still if far from clear.
please provide more info
(0027759)
arun.singh (reporter)
2018-08-09 03:19

Can you detail what is not clear there. The only thing being asked is if the report could be segregated based on subfolders/ folder structure as well instead of default segregation just on root folder and not subfolders. I guess this has been made clear since the very first request. Still let me know if you again fail to understand. This much detail was not needed by even a new person in my team to understand. I assumed you to be an expert here, which has been proven wrong thus far.
(0027760)
fman (administrator)
2018-08-09 07:33

well, what a kind of education.
because you said you are smarter than me just go ahead, fork, do the development ad create pull request.
(0027761)
fman (administrator)
2018-08-09 07:34

waiting for user contribution

- Issue History
Date Modified Username Field Change
2018-07-17 04:20 arun.singh New Issue
2018-07-17 05:31 fman Note Added: 0027698
2018-07-17 05:32 fman Status new => feedback
2018-07-17 05:32 fman QA Team - Task Workflow Status => TBD
2018-07-17 05:32 fman Priority high => normal
2018-07-17 05:32 fman Severity major => feature request
2018-08-07 16:49 fman Note Added: 0027751
2018-08-07 16:49 fman Status feedback => closed
2018-08-07 16:49 fman Assigned To => fman
2018-08-07 16:49 fman Resolution open => unable to reproduce
2018-08-08 04:04 arun.singh Note Added: 0027754
2018-08-08 04:04 arun.singh Status closed => assigned
2018-08-08 04:04 arun.singh Resolution unable to reproduce => reopened
2018-08-08 04:06 arun.singh Note Edited: 0027754 View Revisions
2018-08-08 09:55 fman Note Added: 0027755
2018-08-08 18:45 fman Status assigned => feedback
2018-08-09 03:19 arun.singh Note Added: 0027759
2018-08-09 03:19 arun.singh Status feedback => assigned
2018-08-09 07:33 fman Note Added: 0027760
2018-08-09 07:34 fman Note Added: 0027761
2018-08-09 07:34 fman Status assigned => closed
2018-08-09 07:34 fman Resolution reopened => open



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker