Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008325TestLinkTest Executepublic2018-07-08 14:262018-10-06 12:17
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.17 (2018 Q1) 
Fixed in Version1.9.18 (2018 Q3) 
Summary0008325: Global Admin cannot execute TestCases
DescriptionGlobal admin cannot execute testcases, because the global rights are not checked to display the execution block (see attachment)
Steps To Reproduce1) As Global Admin, go to execution page
2) Try to save a execution => the execution div is not displayed

Additional InformationWorkaround : for each project, define the global admin as an admin, and the execution block will be displayed

PR to follow
TagsNo tags attached.
Database (MySQL,Postgres,etc)Any
BrowserAny
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Capture.PNG [^] (13,090 bytes) 2018-07-08 14:34

- Relationships
related to 0008306closedfman MIGRATE from 1.9.15 - There is no "save" button on test case execution page to save execution result. 

-  Notes
(0027666)
Mr.Bricodage (updater)
2018-07-08 14:28

PR : https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/171 [^]
(0027676)
fman (administrator)
2018-07-09 18:17
edited on: 2018-07-09 18:17

this does not happen on 1.9.18, because changes has been done to tlUserClass hasRight Method

PR can be applied as a Quick & Dirty fix for 1.9.17

(0027677)
Mr.Bricodage (updater)
2018-07-09 18:27

This is weird, cause I fixed it from github yesterday, based on last code. The screen shot has been done with fresh code.
I indicate 1.9.17 only because last github version is not available in drop-down.
(0027678)
Mr.Bricodage (updater)
2018-07-09 18:33

Warning : to reproduce the issue you have to create a new project and try to execute a new testcase, because if you use an old project, project access can have been saved with local admin rights (not inherited)
(0027679)
fman (administrator)
2018-07-09 19:31

Create Test Project PUBLIC & ACTIVE
Create Test Suite
Create ONE TEST CASE
Create Test Plan PUBLIC & ACTIVE
Create Build B1
Link Test Case to Test Plan
Go to execute

Everything is FINE


May be issue happens with PRIVATE TEST PROJECT or TEST PLAN?

I've found this PR that is still open:
https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/111 [^]
(0027680)
Mr.Bricodage (updater)
2018-07-10 10:17

You're Right, we always used private projects and public test plans.
(0027682)
fman (administrator)
2018-07-10 12:21

following note 27680, this means we need to prepare a different scenario to check if issue exists?

please let me know

regards
(0027690)
Mr.Bricodage (updater)
2018-07-12 20:06

The problem can be seen when a user is defined as inherited admin on a private project (just tested doing modification in DB)

Tried to define this trough TestLink GUI, Just tested on last github version :

As an Global Admin

1 - Create Test Project PUBLIC & ACTIVE
2 - Create Test Suite
3 - Create ONE TEST CASE
4 - Create Test Plan PUBLIC & ACTIVE
5 - Create Build B1
6 - Link Test Case to Test Plan
7 - Go to execute

==> Execution CAN be saved

8 - Create Test Plan PRIVATE & ACTIVE
9 - Create Build B1
10 - Link Test Case to Test Plan
11 - Go to execute

==> Execution CAN be saved

1 - Create Test Project PRIVATE & ACTIVE
2 - Create Test Suite
3 - Create ONE TEST CASE
4 - Create Test Plan PUBLIC & ACTIVE
5 - Create Build B1
6 - Link Test Case to Test Plan
7 - Go to execute

==> Execution CAN be saved

8 - Create Test Plan PRIVATE & ACTIVE
9 - Create Build B1
10 - Link Test Case to Test Plan
11 - Go to execute

==> Execution CAN be saved


1 - Check admin userRights on Public Project => "Inherited Admin"
2 - Check admin userRights on Private Project => "Admin"
3 - Change Public Project properties to define the project as private
4 - Check admin userRights on New Private Project => "Admin"
5 - Go to execute

==> Execution CAN be saved



Unable to reproduce through TestLink GUI.


My hypothesis :
1 - there was a way to define a user as inherited admin on a private project through GUI before
2 - I validate the patch on a old project with the problem

Additionnal info :
I switched the project forced in DB to "Inherited Admin" to public, and then to private again => Admin user rights switched from "Inherited Admin" to "Admin"

=> if somebody face the problem, just has to switch project to public, and then to private again to fix it in DB
(0027691)
fman (administrator)
2018-07-12 20:12
edited on: 2018-07-12 20:13

Great Job!.
I'm going to read carefully when I will be fully 'fresh'.
I'm working on the inherit feature I do not know if changes I'm testing (not on official code) will have a good effect on this.
All the role staff with inheritance is a little bit contorted

Talking about roles:
A user has proposed and implemented the DEFAULT ROLE feature, but I'm not sure I'm going to accept the proposed implementation. Surely not AS IS.

thanks again for your collaboration and help.

OFF TOPIC:
Russia 2018 I can NOT provide my support to France (I'm from Argentina :) )

(0027693)
Mr.Bricodage (updater)
2018-07-12 20:17
edited on: 2018-07-12 20:27

OK, I found the way to define a global admin as "Inherited Admin" on private project.

1) create a new user1, globally "<no_rights>"
2) Create a private project PJ1
3) upgrade the user1 to "Admin"
4) check rights on PJ1 (or any other project) for user1 : "Inherited Admin"

(0027694)
Mr.Bricodage (updater)
2018-07-12 20:25

the switch workaround proposed in 0008325:0027690 still works, but it can be difficult to be done if you have a lot of projects
(0027792)
Mr.Bricodage (updater)
2018-08-29 08:51

The issue is still present, I think that mantis ticket should be updated the remove the "fixed" information.
(0027934)
fman (administrator)
2018-10-06 12:17

1.9.18 released

- Issue History
Date Modified Username Field Change
2018-07-08 14:26 Mr.Bricodage New Issue
2018-07-08 14:28 Mr.Bricodage Note Added: 0027666
2018-07-08 14:34 Mr.Bricodage File Added: Capture.PNG
2018-07-09 18:06 fman Relationship added related to 0008306
2018-07-09 18:17 fman Note Added: 0027676
2018-07-09 18:17 fman Note Edited: 0027676 View Revisions
2018-07-09 18:23 fman QA Team - Task Workflow Status => READY FOR TESTING
2018-07-09 18:23 fman Status new => resolved
2018-07-09 18:23 fman Fixed in Version => 1.9.18 (2018 Q3)
2018-07-09 18:23 fman Resolution open => fixed
2018-07-09 18:23 fman Assigned To => fman
2018-07-09 18:27 Mr.Bricodage Note Added: 0027677
2018-07-09 18:33 Mr.Bricodage Note Added: 0027678
2018-07-09 19:31 fman Note Added: 0027679
2018-07-10 10:17 Mr.Bricodage Note Added: 0027680
2018-07-10 12:21 fman Note Added: 0027682
2018-07-12 20:06 Mr.Bricodage Note Added: 0027690
2018-07-12 20:12 fman Note Added: 0027691
2018-07-12 20:13 fman Note Edited: 0027691 View Revisions
2018-07-12 20:17 Mr.Bricodage Note Added: 0027693
2018-07-12 20:25 Mr.Bricodage Note Added: 0027694
2018-07-12 20:27 Mr.Bricodage Note Edited: 0027693 View Revisions
2018-08-29 08:51 Mr.Bricodage Note Added: 0027792
2018-10-06 12:17 fman Note Added: 0027934
2018-10-06 12:17 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker