Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008315TestLinkAPI - XMLRPCpublic2018-06-26 01:032018-10-06 15:41
Reporterrusty 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionduplicate 
PlatformNAOSNAOS VersionNA
Product Version1.9.17 (2018 Q1) 
Fixed in Version 
Summary0008315: No method exists to get all test executions
DescriptionLooks like this has been a feature request for some time.

http://forum.testlink.org/viewtopic.php?f=10&t=8029 [^]

https://www.jetmore.org/john/blog/2012/03/missing-testlink-api-function-getexecutionresults/ [^]

Hard to believe that we can get the latest execution, but not all the executions for a test case on a test plan and/or a build in a test plan.


Proposal to fix:
implement a method called "getExecutionResults" which takes the same parameters as "getLastExecutionResults" and will return a list of execution results.
Steps To ReproduceAttempt to use the API to get more than just the last execution of a test plan, but there is no method to do such. The APIs currently only implement a method called "getLastExecutionResult". Kind of hard to believe that there isn't a method to get all of the execution results to track things like execution times or track items contained in custom fields.
Additional InformationNot sure if this is the place to put feature requests.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
BrowserALL
PHP Version5.0.0+
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
duplicate of 0008218closedfman Add new method getAllExecutionsResults 

-  Notes
(0027635)
rusty (reporter)
2018-06-26 01:26

Looking at the parameters for "getLastExecutionResult", we might need to add parameters to put bounds on how many test case execution results to get.
(0027636)
Mr.Bricodage (updater)
2018-06-26 05:04

Please check 0008218 and provide feedback
(0027637)
rusty (reporter)
2018-06-26 05:30

Thank you, was not aware that the issue had already been resolved.
(0027640)
fman (administrator)
2018-06-26 10:06

Sentences like ' is hard to believe' adds nothing and are IMHO to avoid.
When reporting an issue or requesting a new feature just stick to facts, no other kind of comments are useful, it not my standard but the defacto standard when reporting issues.
(0027644)
rusty (reporter)
2018-06-26 19:55

Fair enough.. I was only trying to communicate how needed and low hanging fruit it was to not have implemented. I am new to the project and will write future bugs in kind.

- Issue History
Date Modified Username Field Change
2018-06-26 01:03 rusty New Issue
2018-06-26 01:26 rusty Note Added: 0027635
2018-06-26 05:04 Mr.Bricodage Note Added: 0027636
2018-06-26 05:30 rusty Note Added: 0027637
2018-06-26 10:03 fman QA Team - Task Workflow Status => TBD
2018-06-26 10:03 fman Priority high => normal
2018-06-26 10:03 fman Severity major => feature request
2018-06-26 10:06 fman Note Added: 0027640
2018-06-26 10:06 fman Relationship added duplicate of 0008218
2018-06-26 10:06 fman Status new => resolved
2018-06-26 10:06 fman Resolution open => duplicate
2018-06-26 10:06 fman Assigned To => fman
2018-06-26 19:55 rusty Note Added: 0027644
2018-10-06 15:41 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker