Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008312TestLinkTest Plan - Assign Test Case Executionpublic2018-06-22 12:192018-10-06 12:17
Reporterdidi 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIE 11 OSWindows & Linux Redhat OS Version7 & 2.6.32-696
Product Version1.9.17 (2018 Q1) 
Fixed in Version1.9.18 (2018 Q3) 
Summary0008312: Click "Remove assignments button" causes a SQL-Error
DescriptionFirst: I have installed on top of 1.9.17, the latest patches, reflected in the Version number 1.9.18 Gaura. This bug happend also on 1.9.17. Q1

If you click the "Remove assignments" Button AND have the Checkbox "Send E-Mail notification to tester"ticked the following ERROR is displayed on the Screen:

ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1 - /* Class:testplan - Method: getFeatureByID */ SELECT parent_id AS tcase_id,tcversion_id,platform_id,TPTCV.id FROM nodes_hierarchy NHTC JOIN testplan_tcversions TPTCV ON TPTCV.tcversion_id = NHTC.id WHERE TPTCV.id IN ()
THE MESSAGE : /* Class:testplan - Method: getFeatureByID */ SELECT parent_id AS tcase_id,tcversion_id,platform_id,TPTCV.id FROM nodes_hierarchy NHTC JOIN testplan_tcversions TPTCV ON TPTCV.tcversion_id = NHTC.id WHERE TPTCV.id IN () Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1


An analysis shows, that the Argument between the brackets of IN() may not be empty, but it is....

https://www.w3resource.com/mysql/comparision-functions-and-operators/in-function.php [^]




Steps To Reproduce1) Create a Testplan
2) add any/one testcase (one is enough to make it reproduceable)
3) Create a build
4) Click Assign Test Case Execution"
5) Click onto this testcase, which brings up the Assign Test Case window in the right Frame
6) Tick the Checkbox in front of the testcase
7) Tick the Checkbox right of the envelope Icon "Send E-Mail notification to tester"
8) Click the button "Remove Assignment"

Wait 2-3 seconds and the Error message will be displayed


Additional Findings:

If you have a user already assigned to a this testcase, a click to the button "Remove Assignment" without having the envelope-Icon ticked, just simply do nothing. The same Action done with the envelope-icon ticked, creates the same error
Additional InformationAdditional Findings:

If you have a user already assigned to a this testcase, a click to the button "Remove Assignment" without having the envelope-Icon ticked, just simply do nothing. The same Action done with the envelope-icon ticked, creates the same error.
TagsNo tags attached.
Database (MySQL,Postgres,etc)10.1.33-MariaDB
BrowserIE11
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Screen Shot 2018-07-21 at 10.34.37.png [^] (61,054 bytes) 2018-07-21 08:37


pdf file icon Bug_8312_Steps_as_Screenshots.pdf [^] (134,191 bytes) 2018-07-24 05:39

- Relationships
child of 0008241closedfman Availables hot-fixes for 1.9.17 & How To get full fixed package from GitHub 

-  Notes
(0027711)
fman (administrator)
2018-07-21 08:37

minor refactoring to gui => see attached image
(0027712)
fman (administrator)
2018-07-21 08:38

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/23d4e6dffb9f9fc55814c73f9e750acee340f588 [^]
(0027713)
fman (administrator)
2018-07-21 08:39

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/23d4e6dffb9f9fc55814c73f9e750acee340f588 [^]
(0027719)
didi (reporter)
2018-07-23 12:33

Installed the Files and most of the misbehaviour is gone except one, which
Described in the additional Information section as follows:

If you have a user already assigned to a this testcase, a click to the button "Remove Assignment" without having the envelope-Icon ticked, just simply do nothing.

=> WORKS NOW
The same Action done with the envelope-icon ticked, creates the same error.
=> CREATES THE ERROR
(0027720)
fman (administrator)
2018-07-23 12:43

Thanks for your tests.
Anyway it's important to understand what is the envelope objective => send mails if action will end OK.
But System is not to verbose, saying at any step : 'OK', or 'KO'.

 
>>If you have a user already assigned to a this testcase, a click to the button "Remove >>Assignment" without having the envelope-Icon ticked, just simply do nothing.
>> => WORKS NOW

works now unfortunatelly is too generic and provide no way to be used as expected result
(0027721)
fman (administrator)
2018-07-23 15:03

unable to reproduce
(0027722)
didi (reporter)
2018-07-24 05:39

I mean with "WORKS NOW, that under that conditions (a.k.a steps to reproduce; as described above) , the SQL-Error does not occur anymore.

I can reproduce this 2.error-leading sequence anytime and have attached now the sequence as a Serie of screenshots and hope, you can Repro it as well - thx
(0027723)
fman (administrator)
2018-07-24 06:58

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/7932e832811f3d1c28268cc931e803ce9c39b7b5 [^]
(0027729)
didi (reporter)
2018-07-24 08:20

Tested and OK - All good now - Bug can be closed - thx
(0027937)
fman (administrator)
2018-10-06 12:17

1.9.18 released

- Issue History
Date Modified Username Field Change
2018-06-22 12:19 didi New Issue
2018-07-21 08:06 fman Assigned To => fman
2018-07-21 08:06 fman Status new => acknowledged
2018-07-21 08:37 fman Note Added: 0027711
2018-07-21 08:37 fman File Added: Screen Shot 2018-07-21 at 10.34.37.png
2018-07-21 08:38 fman Note Added: 0027712
2018-07-21 08:39 fman QA Team - Task Workflow Status => READY FOR TESTING
2018-07-21 08:39 fman Note Added: 0027713
2018-07-21 08:39 fman Status acknowledged => resolved
2018-07-21 08:39 fman Fixed in Version => 1.9.18 (2018 Q3)
2018-07-21 08:39 fman Resolution open => fixed
2018-07-21 08:41 fman Relationship added child of 0008241
2018-07-23 12:33 didi Note Added: 0027719
2018-07-23 12:33 didi Status resolved => assigned
2018-07-23 12:33 didi Resolution fixed => reopened
2018-07-23 12:43 fman Note Added: 0027720
2018-07-23 12:43 fman Status assigned => feedback
2018-07-23 15:03 fman Note Added: 0027721
2018-07-23 15:03 fman Status feedback => resolved
2018-07-23 15:03 fman Resolution reopened => fixed
2018-07-24 05:39 didi Note Added: 0027722
2018-07-24 05:39 didi Status resolved => assigned
2018-07-24 05:39 didi Resolution fixed => reopened
2018-07-24 05:39 didi File Added: Bug_8312_Steps_as_Screenshots.pdf
2018-07-24 06:58 fman Note Added: 0027723
2018-07-24 06:58 fman Status assigned => resolved
2018-07-24 06:58 fman Resolution reopened => fixed
2018-07-24 08:20 didi Note Added: 0027729
2018-10-06 12:17 fman Note Added: 0027937
2018-10-06 12:17 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker