Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008262TestLinkGUIpublic2018-05-14 06:292018-10-06 12:17
Reporterahafiz 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSOS VersionWindows 10
Product Version1.9.17 (2018 Q1) 
Fixed in Version1.9.18 (2018 Q3) 
Summary0008262: Main Page shows blank page after successfully login and displayed Error line.
Descriptionerror stated that : Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in C:\xampp\htdocs\testlink-1.9.17\third_party\phpmailer\PHPMailerAutoload.php on line 45

Steps To Reproduce1. Do fresh installation.
2. after complete installation, create user to login.
3. after successfully create user, Testlink navigate to main page.
4. On Main Page, page blank with error stated on the page.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version7.2.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon Screenshot_1.png [^] (40,957 bytes) 2018-05-14 06:29


png file icon Testlink 1.9.18 with PHP V7.2.5.png [^] (67,561 bytes) 2018-05-16 00:42

- Relationships

-  Notes
(0027458)
ahafiz (reporter)
2018-05-14 08:38

Issue only occur when use PHP Version 7.2.5.

Test and Work fine on PHP Version 5.6.31
(0027467)
fman (administrator)
2018-05-15 18:06

Thanks for info, I'm going to try to upgrade to latest PHPMailer version to understand if this will solve the issue
(0027468)
fman (administrator)
2018-05-15 18:39

Would you mind to test using latest code from github?
I've updated PHPMailer
https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/d46c2cca2189d0418be5100c0451fce212b497b6 [^]
(0027476)
ahafiz (reporter)
2018-05-16 00:41

Hi fman, im test with latest code from GitHub, the issue is fixed on PHP Version 7.2.5 . Please refer the latest attachment for reference.
(0027953)
fman (administrator)
2018-10-06 12:17

1.9.18 released

- Issue History
Date Modified Username Field Change
2018-05-14 06:29 ahafiz New Issue
2018-05-14 06:29 ahafiz File Added: Screenshot_1.png
2018-05-14 08:38 ahafiz Note Added: 0027458
2018-05-15 18:06 fman Note Added: 0027467
2018-05-15 18:39 fman Note Added: 0027468
2018-05-15 18:39 fman Assigned To => fman
2018-05-15 18:39 fman Status new => feedback
2018-05-15 18:39 fman QA Team - Task Workflow Status => TBD
2018-05-16 00:41 ahafiz Note Added: 0027476
2018-05-16 00:41 ahafiz Status feedback => assigned
2018-05-16 00:42 ahafiz File Added: Testlink 1.9.18 with PHP V7.2.5.png
2018-05-16 05:37 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2018-05-16 05:37 fman Status assigned => resolved
2018-05-16 05:37 fman Fixed in Version => 1.9.18 (2018 Q3)
2018-05-16 05:37 fman Resolution open => fixed
2018-10-06 12:17 fman Note Added: 0027953
2018-10-06 12:17 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker