Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008236TestLinkRolespublic2018-04-11 07:002018-10-06 15:41
Reporterquartoxuna 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version 
Summary0008236: Testcase search field does not check for user rights
DescriptionIf a Testcase is searched via the Search Field at the top of the navigation menu, the user is able to see testcases in projects, where the user explicitly has no rights.
Additional InformationIn out setup, every user initially has "no_rights" as the global default.
This means, that for every testproject, the user has the inherited right "no_rights".
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0027290)
fman (administrator)
2018-04-12 18:19

Please get latest code from github, do fresh install, retest and provide feedback
(0027450)
fman (administrator)
2018-05-12 07:37

no more user feedback

- Issue History
Date Modified Username Field Change
2018-04-11 07:00 quartoxuna New Issue
2018-04-12 18:19 fman Note Added: 0027290
2018-04-12 18:19 fman Status new => feedback
2018-05-12 07:37 fman QA Team - Task Workflow Status => TBD
2018-05-12 07:37 fman Note Added: 0027450
2018-05-12 07:37 fman Status feedback => resolved
2018-05-12 07:37 fman Resolution open => unable to reproduce
2018-05-12 07:37 fman Assigned To => fman
2018-10-06 15:41 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker