Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008191TestLinkBug Tracking System - Redmine Integrationpublic2018-02-06 23:382018-04-14 09:04
Reporterhgc2002 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0008191: warning because $issue variables not found in redminerestInterface.class.php exception handlers
DescriptionIn two places at lib/issuetrackerintegration/redminerestInterface.class.php the variable $issue is serialized to be added to the exception information. This is nice but the problem is that $issue does not exist in such routines, so the warning is generated.

In one case an $xml variable has all the issue data and in other case there is a $issueXmlObj variable with the xml object. I've used two easy workarounds:

Place 1:
around line 435 (aprox):
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . serialize($issue));

workaround:
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . print_r($xml,true));

---

Place 2:
around line 469 (aprox.):
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . serialize($issue));

workaround:
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . serialize($issue));
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . print_r($issueXmlObj,true));

Steps To ReproduceCause any problem when creating an issue linked to a test case execution, you'll see the warning in the log file.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.6, but it really doesn't matter
BrowserFirefox quantum 58.0.1 64 bits
PHP Version5.6.11
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0027178)
hgc2002 (reporter)
2018-02-06 23:40

The second workaround (because I did a mistake in the bug description):

Place 2:
around line 469 (aprox.):
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . serialize($issue));

workaround:
$ret = array('status_ok' => false, 'id' => -1, 'msg' => $msg . ' - serialized issue:' . print_r($issueXmlObj,true));
(0027182)
fman (administrator)
2018-02-10 08:37

thanks I'm going to check if already fixed on latest code on github
(0027183)
fman (administrator)
2018-02-10 08:51

1) only one WRONG (as detailed by you) serialize($issue) exists latest code

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/ef1a9c25b4c64e31a56196fcafe1122a0e01d884 [^]
(0027303)
fman (administrator)
2018-04-14 09:04

release 1.9.17

- Issue History
Date Modified Username Field Change
2018-02-06 23:38 hgc2002 New Issue
2018-02-06 23:40 hgc2002 Note Added: 0027178
2018-02-10 08:37 fman Note Added: 0027182
2018-02-10 08:51 fman Note Added: 0027183
2018-02-10 08:51 fman QA Team - Task Workflow Status => TBD
2018-02-10 08:51 fman Fixed in Version => 1.9.17 (2018 Q1)
2018-02-10 08:52 fman Status new => resolved
2018-02-10 08:52 fman Resolution open => fixed
2018-02-10 08:52 fman Assigned To => fman
2018-04-14 09:04 fman Note Added: 0027303
2018-04-14 09:04 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker