Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008183TestLinkTest Executepublic2018-01-16 11:422018-04-15 10:36
Reporterkostgr_2 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.17 (2018 Q1) 
Summary0008183: Link to execution report http://testlink/testlink-code/lnl.php?type=exec&id=61 [^] doesn't work
DescriptionThe link generated for execution report (called from execution history) is not working on dev-version of testlink (1.9.17 dev).

Steps To Reproduce1. Execute test case
2. Open execution report
(see address like http://testlink/testlink-code/lib/execute/execPrint.php?id=61 [^])
3. The link at the bottom of the report doesn't work (apiKey seems to be required but is missing).
TagsNo tags attached.
Database (MySQL,Postgres,etc)everyone
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0007817closedfman Availables hot-fixes for 1.9.16 & How To get full fixed package from GitHub 

-  Notes
(0027149)
kostgr_2 (reporter)
2018-01-16 11:43

Broken link looks like http://testlink/testlink-code/lnl.php?type=exec&id=61 [^]
(0027173)
Mr.Bricodage (updater)
2018-02-05 00:15

Do you point to "direct link" URL displayed at the end of the report?

Can you confirm that the "direct link" available in GUI (click on the icon just before buttons to display the link) is OK ?
(0027232)
fman (administrator)
2018-02-24 15:50

Can you provide detailed steps to reproduce?
I'm not able to understand how do you access to the link
(0027233)
fman (administrator)
2018-02-24 15:57

Error got
Fatal error: Uncaught exception 'Exception' with message 'Aborting - Bad API Key lenght' in /development/github/testlink-code/lnl.php:203 Stack trace: #0 /development/github/testlink-code/lnl.php(22): init_args(Object(database)) #1 {main} thrown in /development/github/testlink-code/lnl.php on line 203
(0027234)
fman (administrator)
2018-02-24 16:05

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/e2d1d1fa51f5437a2d0645abc9964bfa92c0786a [^]
(0027354)
fman (administrator)
2018-04-15 10:36

released

- Issue History
Date Modified Username Field Change
2018-01-16 11:42 kostgr_2 New Issue
2018-01-16 11:43 kostgr_2 Note Added: 0027149
2018-02-05 00:15 Mr.Bricodage Note Added: 0027173
2018-02-24 15:50 fman Note Added: 0027232
2018-02-24 15:50 fman Assigned To => fman
2018-02-24 15:50 fman Status new => feedback
2018-02-24 15:57 fman Note Added: 0027233
2018-02-24 16:05 fman QA Team - Task Workflow Status => READY FOR TESTING
2018-02-24 16:05 fman Note Added: 0027234
2018-02-24 16:05 fman Status feedback => resolved
2018-02-24 16:05 fman Fixed in Version => 1.9.17 (2018 Q1)
2018-02-24 16:05 fman Resolution open => fixed
2018-02-24 16:06 fman Relationship added child of 0007817
2018-04-15 10:36 fman Note Added: 0027354
2018-04-15 10:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker