Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008172TestLinkUsers and Rightspublic2018-01-02 13:292018-04-15 10:36
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0008172: Use existant right 'mgt_unfreeze_req'
DescriptionThe 'right' table already contains a dedicated right for Freeze Requirement feature. The right is named 'mgt_unfreeze_req' (30).

This right is not used by testlink code to allow user to freeze requirement, only to unfreeze. Access to freeze freature is checked according to 'mgt_modify_req' right (11).

Because admin could be interested to provide Freeze/Unfreeze Requirement feature to only a reduce group of people that can modify Requirements, the 'mgt_unfreeze_req' right should be accessible in role management and used by testlink code.
Additional InformationPR to follow
TagsNo tags attached.
Database (MySQL,Postgres,etc)Any
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0027133)
Mr.Bricodage (updater)
2018-01-02 14:25

PR : https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/137 [^]
(0027360)
fman (administrator)
2018-04-15 10:36

released

- Issue History
Date Modified Username Field Change
2018-01-02 13:29 Mr.Bricodage New Issue
2018-01-02 14:25 Mr.Bricodage Note Added: 0027133
2018-01-02 21:44 fman QA Team - Task Workflow Status => READY FOR TESTING
2018-01-02 21:44 fman Status new => resolved
2018-01-02 21:44 fman Resolution open => fixed
2018-01-02 21:44 fman Assigned To => fman
2018-01-02 21:57 Mr.Bricodage Fixed in Version => 1.9.17 (2018 Q1)
2018-04-15 10:36 fman Note Added: 0027360
2018-04-15 10:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker