Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008170TestLinkUsers and Rightspublic2017-12-29 22:032018-04-15 10:36
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0008170: Use existant right 'keyword_assignment'
DescriptionThe 'right' table already contain a dedicated right for Keyword Assign feature. The right is named 'keyword_assignment' (29).

This right is not used by testlink code to verify user access to related feature. Access is checked according to 'Edit Keyword' right.

Because admin could be interested to provide Assign Keyword feature to only a sub- group of people that can edit Keyword, the 'keyword_assignment' right should be accessible in role management and used by testlink code.
Steps To ReproduceN/A
Additional InformationPR to follow
TagsNo tags attached.
Database (MySQL,Postgres,etc)Any
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0027120)
Mr.Bricodage (updater)
2017-12-29 22:10

PR : https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/136 [^]
(0027363)
fman (administrator)
2018-04-15 10:36

released

- Issue History
Date Modified Username Field Change
2017-12-29 22:03 Mr.Bricodage New Issue
2017-12-29 22:10 Mr.Bricodage Note Added: 0027120
2017-12-30 09:40 fman QA Team - Task Workflow Status => READY FOR TESTING
2017-12-30 09:40 fman Status new => resolved
2017-12-30 09:40 fman Fixed in Version => 1.9.17 (2018 Q1)
2017-12-30 09:40 fman Resolution open => fixed
2017-12-30 09:40 fman Assigned To => fman
2018-04-15 10:36 fman Note Added: 0027363
2018-04-15 10:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker