Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008149TestLinkGUIpublic2017-12-01 18:472018-10-06 15:42
Reporteradolf1990 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0008149: 'Update active, required, monitorable' button on 'Assing custom fields' section doesn't work
DescriptionTesting Testlink 1.9.17 Alan Turing, we figured out a problem: when we wanted to assign a custom field recently created to a project as required, button 'Update active, required, monitorable' clears the check columns, screenshots attached
Steps To ReproduceCreate a project
Create a custom field
Go to 'Assing custom fields' interface
Check 'Required' column to assign as requiered
Click 'Update active, required, monitorable' button
Additional InformationLatest version from github - Testlink 1.9.17 Alan Turing
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
BrowserFirefox
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon tl9-17.PNG [^] (30,693 bytes) 2017-12-01 18:47


png file icon tl9-17-2.PNG [^] (30,481 bytes) 2017-12-01 18:48


png file icon tl9-17-3.PNG [^] (30,486 bytes) 2017-12-01 18:48

- Relationships

-  Notes
(0027055)
fman (administrator)
2017-12-05 05:53

Tested on latest code from github on mac os using MAMP (PHP 7.1.6), unable to reproduce
(0027127)
fman (administrator)
2017-12-30 10:15

no more user feedback
(0027812)
bankorga@aab.de (reporter)
2018-09-06 11:45

Hi Francisco,
I have the same problem with tl 1.9.7 version. It's running under php version 5.6.25.

While assigning a custom fields to the test projekt, the check box "active" is setting by default. Further I activate the check box "required" and continue by clicking on the button "update active, required, monitorable". This action clear all check boxes, so I can't change it any more.

Can you please check/explain the reason for this behavior?

Let me know if you need futher details.

thanks
regards
yury
(0027813)
fman (administrator)
2018-09-06 12:19

Please get latest code from github, do fresh install retest and provide feedback
(0027814)
bankorga@aab.de (reporter)
2018-09-06 12:57

We've got last commit (804a962) and install it. Unfortunately the error still exists.
(0027815)
bankorga@aab.de (reporter)
2018-09-06 14:56

we've solved the problem after updating php version to 7.2.9
(0027817)
fman (administrator)
2018-09-06 15:23

Thanks a lot for the info!!!
(0027966)
fman (administrator)
2018-10-06 15:42

PHP > 7.2 is needed

- Issue History
Date Modified Username Field Change
2017-12-01 18:47 adolf1990 New Issue
2017-12-01 18:47 adolf1990 File Added: tl9-17.PNG
2017-12-01 18:48 adolf1990 File Added: tl9-17-2.PNG
2017-12-01 18:48 adolf1990 File Added: tl9-17-3.PNG
2017-12-05 05:53 fman Note Added: 0027055
2017-12-05 05:53 fman Assigned To => fman
2017-12-05 05:53 fman Status new => feedback
2017-12-30 10:15 fman QA Team - Task Workflow Status => TBD
2017-12-30 10:15 fman Note Added: 0027127
2017-12-30 10:15 fman Status feedback => resolved
2017-12-30 10:15 fman Resolution open => unable to reproduce
2018-09-06 11:45 bankorga@aab.de Note Added: 0027812
2018-09-06 12:19 fman Note Added: 0027813
2018-09-06 12:57 bankorga@aab.de Note Added: 0027814
2018-09-06 14:56 bankorga@aab.de Note Added: 0027815
2018-09-06 15:23 fman Note Added: 0027817
2018-10-06 15:42 fman Note Added: 0027966
2018-10-06 15:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker