Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008140TestLinkTest Execute - Navigatorpublic2017-11-21 10:372017-12-07 12:38
Reporteranthony.cervi 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version 
Summary0008140: Test execution detail page throws an HTTP 500 error
DescriptionWe use Testlink 1.9.16.

By clicking on a test case in the test case tree on the Test Execution page, but that on some not on all test cases, it launches a blank page on Firefox and HTTP 500 Internal server error on Internet Explorer .

Please, take a look.
Steps To Reproduce-> Login and select a project
-> Go to Test Execution
-> In left pane, expand the tree
-> Click on any testcase

Expected: Testcase detail should be displayed in right pane

Actual: On IE, it displays
"The website cannot display the page
 
 HTTP 500
 
Most likely causes:
•The website is under maintenance.
•The website has a programming error.
   

What you can try:

Refresh the page.

Go back to the previous page.

More information

This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

For more information about HTTP errors, see Help."

On Firefox, it throws a blank page without any errors.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon 2017-11-21 11_33_57-TestLink 1.9.16 (Moka pot).png [^] (44,716 bytes) 2017-11-21 10:37

- Relationships

-  Notes
(0027028)
fman (administrator)
2017-11-25 08:48

please get latest code from github, do fresh install, retest & provide feedback
(0027034)
anthony.cervi (reporter)
2017-11-29 09:48

i have a problem with the version 1.9.17 after copy latest code from github and copy config_db_inc.php and config.inc.php, and delete directory Install, login page is blank !!
(0027076)
stojex (reporter)
2017-12-06 11:32
edited on: 2017-12-06 11:47

I have this same problem. On 1.9.16 when i execute test case server throw 500 internal server error.
On 1.9.17 (i download today from GitHub) installation is complete (succesfull), but login page didn't work. Login page is blank.

userlog0.log:
[>>][5a27d2ecc83c5859506982][DEFAULT][/index.php][17/Dec/6 11:22:20]
[>>][5a27d2ed0398a569403068][DEFAULT][/index.php][17/Dec/6 11:22:21]
[>>][5a27d2ed37994390803747][DEFAULT][/index.php][17/Dec/6 11:22:21]
[>>][5a27d2ed653e6994065138][DEFAULT][/index.php][17/Dec/6 11:22:21]
[>>][5a27d2ed98309248264433][DEFAULT][/index.php][17/Dec/6 11:22:21]


userlog1.log:
[<<][5a27d2ecc83c5859506982][DEFAULT][/index.php][17/Dec/6 11:22:20][17/Dec/6 11:22:20][took 0.0036900000000001 secs]
[<<][5a27d2ed0398a569403068][DEFAULT][/index.php][17/Dec/6 11:22:21][17/Dec/6 11:22:21][took 0.004096 secs]
[<<][5a27d2ed37994390803747][DEFAULT][/index.php][17/Dec/6 11:22:21][17/Dec/6 11:22:21][took 0.002695 secs]
[<<][5a27d2ed653e6994065138][DEFAULT][/index.php][17/Dec/6 11:22:21][17/Dec/6 11:22:21][took 0.002879 secs]
[<<][5a27d2ed98309248264433][DEFAULT][/index.php][17/Dec/6 11:22:21][17/Dec/6 11:22:21][took 0.0046040000000001 secs]


Ubuntu Server 17.10
PHP 7.1
mysql


Apache log:
[Wed Dec 06 12:42:21.300884 2017] [php7:error] [pid 1107] [client 192.168.2.xx:59288] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86
[Wed Dec 06 12:44:55.813538 2017] [php7:error] [pid 1094] [client 192.168.2.xx:59310] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86
[Wed Dec 06 12:45:02.842555 2017] [php7:error] [pid 929] [client 192.168.2.xx:59311] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86
[Wed Dec 06 12:45:03.801792 2017] [php7:error] [pid 927] [client 192.168.2.xx:59323] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86
[Wed Dec 06 12:45:04.160891 2017] [php7:error] [pid 928] [client 192.168.2.xx:59326] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86
[Wed Dec 06 12:45:04.314380 2017] [php7:error] [pid 1097] [client 192.168.2.xx:59327] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86
[Wed Dec 06 12:45:50.635390 2017] [php7:error] [pid 926] [client 192.168.2.xx:59401] PHP Fatal error: Uncaught Error: Call to undefined function getSSODisable() in /var/www/html/index.php:86\nStack trace:\n#0 /var/www/html/index.php(22): initEnv()\n#1 {main}\n thrown in /var/www/html/index.php on line 86

(0027077)
stojex (reporter)
2017-12-06 12:51

I solved the problem with the white page. anthony.cervi you must clone repository from git. The ZIP file is damaged and lacks many valid files.


git clone https://github.com/TestLinkOpenSourceTRMS/testlink-code.git [^]
(0027078)
anthony.cervi (reporter)
2017-12-07 10:25

no change for me....
(0027079)
fman (administrator)
2017-12-07 11:02

@anthony.cervi
your best approach to solve this is (IMHO):
get bitnami installer, or bitnami VM or bitnami DOCKER with 1.9.16
(0027080)
anthony.cervi (reporter)
2017-12-07 12:38

i want say no change for Test execution detail page throws an HTTP 500 error

- Issue History
Date Modified Username Field Change
2017-11-21 10:37 anthony.cervi New Issue
2017-11-21 10:37 anthony.cervi File Added: 2017-11-21 11_33_57-TestLink 1.9.16 (Moka pot).png
2017-11-25 08:48 fman Note Added: 0027028
2017-11-25 08:48 fman Assigned To => fman
2017-11-25 08:48 fman Status new => feedback
2017-11-29 09:48 anthony.cervi Note Added: 0027034
2017-11-29 09:48 anthony.cervi Status feedback => assigned
2017-12-06 11:32 stojex Note Added: 0027076
2017-12-06 11:36 stojex Note Edited: 0027076 View Revisions
2017-12-06 11:47 stojex Note Edited: 0027076 View Revisions
2017-12-06 12:51 stojex Note Added: 0027077
2017-12-07 10:25 anthony.cervi Note Added: 0027078
2017-12-07 11:02 fman Note Added: 0027079
2017-12-07 12:38 anthony.cervi Note Added: 0027080



Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker