Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008054TestLinkBug Tracking System - Redmine Integrationpublic2017-08-11 12:422017-10-16 07:58
Reporterbb3 
Assigned Tofman 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSCent OSOS Version7
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2017 Q2) 
Summary0008054: Issue tracking management (PHP Version 7.1.x Issue)
DescriptionHi,

We are Migrating testlink from 1.9.3 to 1.9.16. we set up every thing.

we struct at configuring redmine to testlink

<issuetracker>
<apikey>apikey</apikey>
<uribase>http://redmineip/</uribase> [^] [^]
<uriview>http://redmineip/issues/</uriview> [^] [^]
</issuetracker>

i used redmine admin apikey.

When we click on check connection we get an blank screen.
 
Then i check the log file (/var/www/html/testlink-code-1.9.16/logs/userlog1.log), i'm getting below error.

 [17/Aug/11 12:27:43][WARNING][72fa24fe787f5e1e428459a91235cba0][GUI]
                E_NOTICE
Undefined index: checkConnection - in /var/www/html/testlink-code-1.9.16/lib/issuetrackers/issueTrackerCommands.class.php - Line 72
[<<][598da2bf72e6d928768445][DEFAULT][/lib/issuetrackers/issueTrackerEdit.php][17/Aug/11 12:27:43][17/Aug/11 12:27:43][took 0.005683 secs]
"userlog1.log" 829L, 91249C
TagsNo tags attached.
Database (MySQL,Postgres,etc)Maria Db 10.1
BrowserTried in google and mozilla
PHP Version7.1
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filestxt file icon strings.txt [^] (191,107 bytes) 2017-08-18 16:10 [Show Content]
? file icon issueTrackerCommands.class.php [^] (7,074 bytes) 2017-08-18 16:10

- Relationships
related to 0008036resolvedfman When trying to execute a test plan the steps are not displayed and no radio buttons (PHP 7.1.x version issue) 
related to 0007967resolvedfman Custom fields redmine 
child of 0007817new Availables hot-fixes for 1.9.16 & How To get full fixed package from GitHub 

-  Notes
(0026707)
fman (administrator)
2017-08-14 16:37
edited on: 2017-08-14 16:37

see configuration on the related ticket 0007967, your one seems incomplete

(0026708)
fman (administrator)
2017-08-14 16:43

Tested with following config (using BITNAMI test on browser option => server up for just 1 hour)

<issuetracker>
<apikey>31cfa07b6df31f2b2f5f1d036d4217b2bc03ee4f</apikey>
<uribase>http://ec2-34-229-156-130.compute-1.amazonaws.com/</uribase> [^]
<uriview>http://ec2-34-229-156-130.compute-1.amazonaws.com//issues/</uriview> [^]
</issuetracker>

Using Latest Code from GitHub => OK
(0026709)
fman (administrator)
2017-08-14 16:45

PHP 7.1.x issue
Tested on 1.9.16 => VERIFIED


Fatal error: Uncaught ArgumentCountError: Too few arguments to function redminerestInterface::__construct(), 2 passed in /development/tl-mixed/tl-releases/testlink-1.9.16/lib/issuetrackers/issueTrackerCommands.class.php on line 268 and exactly 3 expected in /development/tl-mixed/tl-releases/testlink-1.9.16/lib/issuetrackerintegration/redminerestInterface.class.php:28 Stack trace: #0 /development/tl-mixed/tl-releases/testlink-1.9.16/lib/issuetrackers/issueTrackerCommands.class.php(268): redminerestInterface->__construct(15, '<issuetracker>\r...') #1 /development/tl-mixed/tl-releases/testlink-1.9.16/lib/issuetrackers/issueTrackerEdit.php(23): issueTrackerCommands->checkConnection(Object(stdClass), Array) 0000002 {main} thrown in /development/tl-mixed/tl-releases/testlink-1.9.16/lib/issuetrackerintegration/redminerestInterface.class.php on line 28
(0026710)
fman (administrator)
2017-08-14 17:06

Issue has been solved on latest code on github

quick fix

edit file: issueTrackerCommands.class.php

change following line:
    $its = new $class2create($argsObj->type,$argsObj->cfg);

to

$its = new $class2create($argsObj->type,$argsObj->cfg,$argsObj->name);
(0026731)
bb3 (reporter)
2017-08-17 10:35

I did changes to issueTrackerCommands.class.php file, still same issue we are facing

issue is at line 72, please look at the below error log


Undefined index: checkConnection - in /var/www/html/testlink-code-1.9.16/lib/issuetrackers/issueTrackerCommands.class.php - Line 72

and in test execution page also we are getting blank screen.
(0026732)
bb3 (reporter)
2017-08-17 10:49

How the ticket has been moved to resolved status?

with out any confirmation from my end weather the issue is resolved or not.
(0026733)
fman (administrator)
2017-08-17 11:05

Dear user:
I've set to resolved because I've tested it, and from my point of view it was resolved, anyway if issue is not solved you can do a very simple and more constructive action than adding a not polite note 0026732 => reopen it.
(0026734)
fman (administrator)
2017-08-17 11:28

I've remember an important thing: Dev Team set resolved status to comunicate with user.
If everything is ok reporter MUST CLOSE ISSUE.
if issue is not resolved reporter WILL REOPEN IT.
(0026735)
fman (administrator)
2017-08-17 11:29

Please enable maximun level of error reporting on your php, with display error on screen.
This way we are going to get useful info instead of a blank screen
(0026736)
bb3 (reporter)
2017-08-17 11:37

could you please guide how to enable maximum level of error reporting
(0026738)
bb3 (reporter)
2017-08-18 07:42

we are migrating testlink from server another server as well as migrating testlink version from 1.9.3 to 1.9.16. From past two weeks i'm working and struct at this place, i googled the issue for solution, but no use. and i don't have hope that i'll find solution for this.


just tell me where can i find step by step installation guide for testlink 1.9.3, so that we will just migrate the server and go through with old version.
(0026739)
bb3 (reporter)
2017-08-18 07:43

Please fman ltleast do this small favour
(0026741)
fman (administrator)
2017-08-18 14:02

@bb3
I really do not understand what is your issue.
I've asked an action on your side on note 26735 without any luck.
For some simple things like request on that note IMHO you can get the info you need with google search like:
php increase error reporting

https://www.google.it/search?q=php+increase+error+reporting&oq=php+increase+error+&aqs=chrome.1.69i57j0.7093j0j7&sourceid=chrome&ie=UTF-8 [^]

You can use also
https://stackoverflow.com/questions/5438060/showing-all-errors-and-warnings [^]


Then regarding your note 26738, I've worked on it and IMHO issue is solved.
I'm going to retest getting 1.9.16 and doing a fresh install.
a sentence like '.. and I don't have hope that I'll find solution for this ...' are useless and provide no value.
Do not use the issue tracker to express your frustration with one thing that can be solved.

In addition, the step by step installation guide does not exist, because there is an installer that does all the work.

Please try to fulfill my request in order to allow me to provide you help
(0026747)
fman (administrator)
2017-08-18 15:51
edited on: 2017-08-18 15:58

1. download 1.9.16 from SourceForge
2. install (using mamp PRO with PHP 7.1.6)
3. create a Test Project
4. create an issue tracker of Redmine type with following (not working) configuration

<issuetracker>
<apikey>REDMINE API KEY</apikey>
<uribase>http://tl.m.remine.org</uribase> [^]
<uriview>http://tl.m.remine.org/issues/</uriview> [^] <!-- for Redmine 1.x add show/ -->
<!-- Project Identifier is NEEDED ONLY if you want to create issues from TL -->
<projectidentifier>REDMINE PROJECT IDENTIFIER
 You can use numeric id or identifier string
</projectidentifier>
</issuetracker>

5. Save it
6. Access to issue tracker on edit mode, and click on Check Connection Button
I've got

Fatal error: Uncaught ArgumentCountError: Too few arguments to function redminerestInterface::__construct(), 2 passed in /development/tl-mixed/tl-releases/1.9.16-fresh/lib/issuetrackers/issueTrackerCommands.class.php on line 268 and exactly 3 expected in /development/tl-mixed/tl-releases/1.9.16-fresh/lib/issuetrackerintegration/redminerestInterface.class.php:28 Stack trace: #0 /development/tl-mixed/tl-releases/1.9.16-fresh/lib/issuetrackers/issueTrackerCommands.class.php(268): redminerestInterface->__construct(15, '<issuetracker>\r...') #1 /development/tl-mixed/tl-releases/1.9.16-fresh/lib/issuetrackers/issueTrackerEdit.php(23): issueTrackerCommands->checkConnection(Object(stdClass), Array) 0000002 {main} thrown in /development/tl-mixed/tl-releases/1.9.16-fresh/lib/issuetrackerintegration/redminerestInterface.class.php on line 28

ERROR

7. Proceed to edit file as indicated in note
8. Retest starting on step 5. => no more ERROR ON SCREEN.

This test confirms that the fix is OK.

You need no more than 10 minutes to do the same test I've done starting with a FRESH (i.e. new install) of 1.9.16, and verify that fix solves this problem (not other open problems with Redmine integration).
This will be very useful for me

KInd regards

(0026748)
fman (administrator)
2017-08-18 16:09

attached files fixes this issue
(0026799)
fman (administrator)
2017-08-30 16:23

no more user feedback
(0026937)
mytestlink2017 (reporter)
2017-10-16 07:49

Sorry for interruptting in this ticket.

I meet the same issue in my Testlink 1.9.16.

After I copy attached files into Testlink 1.9.16, and issue is still not fixed.

In the error.log of Apache2 folder, please refer to it below:
*************************************************************
[Mon Oct 16 15:34:19.816395 2017] [:error] [pid 3726] [client 10.25.15.7:46652] PHP Fatal error: Uncaught Error: Call to undefined function simplexml_load_string() in /var/www/html/testlink/lib/functions/tlIssueTracker.class.php:713\nStack trace:\n#0 /var/www/html/testlink/lib/functions/tlIssueTracker.class.php(227): tlIssueTracker->checkXMLCfg('dd')\n#1 /var/www/html/testlink/lib/issuetrackers/issueTrackerCommands.class.php(196): tlIssueTracker->update(Object(stdClass))\n#2 /var/www/html/testlink/lib/issuetrackers/issueTrackerEdit.php(23): issueTrackerCommands->doUpdate(Object(stdClass), Array)\n#3 {main}\n thrown in /var/www/html/testlink/lib/functions/tlIssueTracker.class.php on line 713, referer: http://10.25.15.9:8080/testlink/lib/issuetrackers/issueTrackerEdit.php?doAction=edit&id=1 [^]
**************************************************************

- Issue History
Date Modified Username Field Change
2017-08-11 12:42 bb3 New Issue
2017-08-14 16:37 fman Note Added: 0026707
2017-08-14 16:37 fman Note Edited: 0026707 View Revisions
2017-08-14 16:37 fman Assigned To => fman
2017-08-14 16:37 fman Status new => feedback
2017-08-14 16:43 fman Note Added: 0026708
2017-08-14 16:45 fman Note Added: 0026709
2017-08-14 16:46 fman QA Team - Task Workflow Status => TBD
2017-08-14 16:46 fman Fixed in Version => 1.9.17 (2017 Q2)
2017-08-14 16:46 fman Summary Issue tracking management => Issue tracking management (PHP Version 7.1.x Issue)
2017-08-14 17:06 fman Note Added: 0026710
2017-08-14 17:07 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2017-08-14 17:07 fman Status feedback => resolved
2017-08-14 17:07 fman Resolution open => fixed
2017-08-14 17:07 fman Relationship added child of 0007817
2017-08-17 10:35 bb3 Note Added: 0026731
2017-08-17 10:49 bb3 Note Added: 0026732
2017-08-17 11:05 fman Note Added: 0026733
2017-08-17 11:28 fman Note Added: 0026734
2017-08-17 11:29 fman Note Added: 0026735
2017-08-17 11:37 bb3 Note Added: 0026736
2017-08-18 07:42 bb3 Note Added: 0026738
2017-08-18 07:43 bb3 Note Added: 0026739
2017-08-18 14:02 fman Note Added: 0026741
2017-08-18 15:51 fman Note Added: 0026747
2017-08-18 15:58 fman Note Edited: 0026747 View Revisions
2017-08-18 15:58 fman Status resolved => new
2017-08-18 15:58 fman Status new => feedback
2017-08-18 16:09 fman Note Added: 0026748
2017-08-18 16:10 fman File Added: strings.txt
2017-08-18 16:10 fman File Added: issueTrackerCommands.class.php
2017-08-18 16:52 fman Relationship added related to 0008036
2017-08-18 17:15 fman Relationship added related to 0007967
2017-08-30 16:23 fman Note Added: 0026799
2017-08-30 16:23 fman Status feedback => resolved
2017-10-16 07:49 mytestlink2017 Note Added: 0026937



Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker