Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008051TestLinkTest Execute - 'Save and move to next'public2017-08-10 22:012018-04-15 10:36
Reporterpsychiclocust 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0008051: Firefox 55 : All the "click set to" and "click set to x and move to next" buttons fails
DescriptionOn execution of a test, all the "click set to" and "click set to x and move to next" buttons fails. The JS console returns the following error : "ReferenceError: submit is not defined"

Luckily after having click one of these buttons, everything is recorded after clicking the "move to next case" button.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
BrowserFirefox 55.0 (32 bits)
PHP Version5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon Capture.JPG [^] (11,069 bytes) 2017-08-15 08:25


jpg file icon Capture2.JPG [^] (17,150 bytes) 2017-08-15 08:25

- Relationships
related to 0008145new Sme as 0008051 

-  Notes
(0026683)
fman (administrator)
2017-08-14 10:13

would you mind to provide better details to understand what is the problem?
(0026714)
psychiclocust (reporter)
2017-08-15 08:32

When I click on one of the smileys or the wheels (see capture.jpg) after having filled a test case with execution details, in Firefox I get the error "submit is not defined" (see capture2.jpg) in the console and nothing happens (test case is not refreshed and updated when I click on a smiley or I don't go to next test case when I click on a wheel).

However as I was saying by clicking "Move to the next test case" after clicking wheel or smiley I do go to the next test case and the status of the origin test case is correctly saved (passed, failed or blocking).
(0026719)
fman (administrator)
2017-08-15 15:44

Thanks for the details, now it will be possible to try to understand what is happening.
It would be possible for you to test (may be) with a portable firefox version < 55 ?
(0026892)
ccupeiro (reporter)
2017-10-03 06:26

Hi!

I've been having the same error and , as you suggested, I've tested with portable firefox 52.0.2 and the error continue happening. There are some news about this?? Thanks for all!
(0026907)
pharmmed (reporter)
2017-10-09 13:19

we have the same issue here with firefox 45.8 and 52.4
It works ok in chrome but no reaction to any of the execution buttons in firefox since update from Padawan to Moka pot
(0026909)
fman (administrator)
2017-10-09 17:05

tested with latest code from github, using mampPro on Mac with php 7.1, and firefox 56.0 => unable to reproduce
(0026913)
pharmmed (reporter)
2017-10-10 07:21
edited on: 2017-10-10 08:00

I just installed the latest Firefox version and tested it again, problem remains, so it's not the specific firefox version at fault. I'll check the php version.

UPDATE: php is v. 5.5.9, so this might be the cause. We'll have to migrate to a different server in order to upgrade to latest php - I'll post an update when we're done

(0026925)
fman (administrator)
2017-10-10 20:58

ok, thanks a lot for your collaboration
(0027008)
pharmmed (reporter)
2017-11-09 15:52

Tested with PHP 7.0 and FF 5.4.1 the problem remains, so it's either not PHP or the problem is fixed in php 7.1 ? (we currently can't update to 7.1)
any other ideas?
(0027165)
dr.jorge (reporter)
2018-01-26 09:41

Unfortunately, after upgrading to 1.9.16 GA we were facing the same problem. PHP 5.5.34 or 7.0.22; FF52 ESR or 57.

After a little investigation I could find a quick fix for Firefox: the smiley-buttons contain JS in their onclick attribute:

onclick="document.getElementById('save_button_clicked').value='4';
                        document.getElementById('statusSingle_4').value='p';
                        document.getElementById('save_results').value=1;
                        submit();"
                        
If you alter the "submit();" part to a full object path "document.forms['execSetResults'].submit();" then it instantly works with Firefox. The change is according to Mozilla documentation found here: https://developer.mozilla.org/en-US/docs/Web/API/HTMLFormElement/submit [^]

I will install a staging instance next week including this change to check if it still works with Chrome. But I'm confident. :)
(0027166)
gavenkoa (reporter)
2018-01-29 09:37
edited on: 2018-01-29 09:40

I have same issue as described for TestLink v1.9.16 from Bitnami in Firefox v58. I see errors in dev console:

ReferenceError: submit is not defined (on click) /testlink/lib/execute/execSetResults.php:4:25

At the same time it works with Chrome v64.0.3282.119

(0027168)
dr.jorge (reporter)
2018-01-29 14:57

I have identified the affected file:

/gui/templates/execute/inc_exec_img_controls.tpl (rows 93 and 108)

It seems like in the meantime (since release of 1.9.16 GA), there has been a change of submit trigger for the buttons. Originally, the same fix as proposed by me in my comment above has been committed to GitHub - but now commented out in favour of a new submit method called "doSubmitForHTML5();"

So the (usual) recommendation seems to be true once again: Upgrade to the latest GitHub version if you can. Currently, it's not a possible option for us to do so, therefore we need to keep the "GA" and patch manually.

HTH anyone out there.
(0027176)
fman (administrator)
2018-02-06 11:40

@dr.jorge => Thanks, I'm going to check
(0027177)
hgc2002 (reporter)
2018-02-06 22:14
edited on: 2018-02-06 22:14

Workaround "document.forms['execSetResults'].submit();"
tested with FF quantum 58.0.1 64 bits (works),
Chrome 63.0.3239.132 64 bits (works), PHP 5.6.11, MySQL 5.6.25
(actually it is XAMPP 5.6.11 on Windows).
TL is 1.9.16 downloaded from SourceForge on 2018-02-01
Apparently SourceForge version is from 2017-01-21

(0027179)
dr.jorge (reporter)
2018-02-07 06:54

@hgc2002: Please note that my workaround doesn't work with mandatory custom fields for test execution.

Unfortunately, I found the ticket 7886 after my previous comment. And 7886 is the cause why the more complicated "doSubmitForHTML5();" had been introduced in favour of the simple submit qualifier.

See the following commit for a full list of changes:

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a8c2a36118c19b5a679d297a78896e46d917bfa4 [^]

We have a staging instance, running 1.9.16 GA with only replacement of the 5 files from the commit mentioned above. And it seems to do fine.
(0027180)
hgc2002 (reporter)
2018-02-07 11:47
edited on: 2018-02-07 11:47

@dr.jorge thanks! I'll try that.

(0027181)
hgc2002 (reporter)
2018-02-09 15:26
edited on: 2018-02-09 15:26

@dr.jorge, it works great. Thanks!

(0027190)
fman (administrator)
2018-02-10 09:05

@dr.jorge: can you please confirm that issue on latest code is fixed ?

regards
(0027193)
dr.jorge (reporter)
2018-02-12 08:47

Did a quick check this morning:

1. wget of latest github & install
2. Create 2 test cases, fill testplan and start
3. checked all six buttons of execution (including the "move to next" variants)
(Note: did tests as admin, but this shouldn't affect general behavior)

Environment: Win7 with FF 52.6 ESR 32bit and FF 57.0.3 Portable 64bit

Result: for me everything seems to do fine. Any github release after 19.03.2017 shouldn't have this issue any longer.
(0027355)
fman (administrator)
2018-04-15 10:36

released

- Issue History
Date Modified Username Field Change
2017-08-10 22:01 psychiclocust New Issue
2017-08-14 10:13 fman Note Added: 0026683
2017-08-14 15:23 fman Assigned To => fman
2017-08-14 15:23 fman Status new => feedback
2017-08-15 08:25 psychiclocust File Added: Capture.JPG
2017-08-15 08:25 psychiclocust File Added: Capture2.JPG
2017-08-15 08:32 psychiclocust Note Added: 0026714
2017-08-15 08:32 psychiclocust Status feedback => assigned
2017-08-15 15:44 fman Note Added: 0026719
2017-08-15 15:44 fman Status assigned => feedback
2017-10-03 06:26 ccupeiro Note Added: 0026892
2017-10-09 13:19 pharmmed Note Added: 0026907
2017-10-09 17:05 fman Note Added: 0026909
2017-10-10 07:21 pharmmed Note Added: 0026913
2017-10-10 08:00 pharmmed Note Edited: 0026913 View Revisions
2017-10-10 20:58 fman Note Added: 0026925
2017-11-09 15:52 pharmmed Note Added: 0027008
2017-11-25 08:45 fman Relationship added related to 0008145
2018-01-26 09:41 dr.jorge Note Added: 0027165
2018-01-29 09:37 gavenkoa Note Added: 0027166
2018-01-29 09:40 gavenkoa Note Edited: 0027166 View Revisions
2018-01-29 14:57 dr.jorge Note Added: 0027168
2018-02-06 11:40 fman Note Added: 0027176
2018-02-06 22:14 hgc2002 Note Added: 0027177
2018-02-06 22:14 hgc2002 Note Edited: 0027177 View Revisions
2018-02-07 06:54 dr.jorge Note Added: 0027179
2018-02-07 11:47 hgc2002 Note Added: 0027180
2018-02-07 11:47 hgc2002 Note Edited: 0027180 View Revisions
2018-02-09 15:26 hgc2002 Note Added: 0027181
2018-02-09 15:26 hgc2002 Note Edited: 0027181 View Revisions
2018-02-10 09:05 fman Note Added: 0027190
2018-02-12 08:47 dr.jorge Note Added: 0027193
2018-02-22 20:55 fman QA Team - Task Workflow Status => READY FOR TESTING
2018-02-22 20:55 fman Status feedback => resolved
2018-02-22 20:55 fman Fixed in Version => 1.9.17 (2018 Q1)
2018-02-22 20:55 fman Resolution open => fixed
2018-04-15 10:36 fman Note Added: 0027355
2018-04-15 10:36 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker