Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008036TestLinkTest Execute - Issue at Step Levelpublic2017-07-26 14:582018-04-14 09:04
Reporterferemily 
Assigned Tofman 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0008036: When trying to execute a test plan the steps are not displayed and no radio buttons (PHP 7.1.x version issue)
DescriptionI have created a test plan, build, etc. Ready to start executing tests. When I click on a test the right panel of the browser is white with no information (true for chrome,firefox and safari)
Steps To Reproducelog into testlink
Go to Execute tests
Click on a test to run the steps

Expected result
The right panel lists the steps withPass/fail/blocked radio buttons

Actual results - white screen
Additional Informationhttps://www.screencast.com/t/Sil1W2OuKEO [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
Browserchrome, firefox and safari
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
duplicate of 0008015closedfman Unable to execute test cases (PHP 7.1.x issue) 
related to 0008054closedfman Issue tracking management (PHP Version 7.1.x Issue) 
related to 0007967closedfman Custom fields redmine 
child of 0007817closedfman Availables hot-fixes for 1.9.16 & How To get full fixed package from GitHub 

-  Notes
(0026659)
fman (administrator)
2017-07-31 12:44
edited on: 2017-07-31 12:47

PHP version?
Webserver type & version?
what about using bitnami installer and retest?

(0026662)
feremily (reporter)
2017-08-01 14:14

nginx version: nginx/1.12.0
PHP 7.1.4

https://github.com/TestLinkOpenSourceTRMS/testlink-code/blob/testlink_1_9/README [^]

No we do not use bitnami installers
(0026703)
feremily (reporter)
2017-08-14 15:38

this is not fixed. There is another ticket reporting the same behavior, you response to him does not apply to us (or at least we have different versions of PHP - so there is confusion due to lack of explanation)
(0026706)
fman (administrator)
2017-08-14 16:02

This ticket has TWO tickets related, one, unfortunately, was wrong and was removed.
The only remaining ticket has IMHO the explanation PHP 7.1. x is more strict that 5.5 with variable type.

Hope now things will be clear.
(0026711)
feremily (reporter)
2017-08-14 17:41

Ok - so we need to downgrade to 5.5?
(0026713)
fman (administrator)
2017-08-15 08:20

Please give a look to http://mantis.testlink.org/view.php?id=8015#c26696 [^]
(0026716)
feremily (reporter)
2017-08-15 15:05

worked beautifully

fixed on TestLink code on GitHub
Quick fix
edit file
C:\xampp\htdocs\testlink\lib\execute\execSetResults.php

and add before this loop:

  foreach($locationFilters as $locationKey => $filterValue)
  {

Following lines

  $finalFilters = array();
  $guiObj->design_time_cfields = array();

fixed our issue
(0026717)
fman (administrator)
2017-08-15 15:40

great!
(0027319)
fman (administrator)
2018-04-14 09:04

release 1.9.17

- Issue History
Date Modified Username Field Change
2017-07-26 14:58 feremily New Issue
2017-07-31 12:44 fman Note Added: 0026659
2017-07-31 12:46 fman QA Team - Task Workflow Status => TBD
2017-07-31 12:46 fman Priority immediate => high
2017-07-31 12:47 fman Note Edited: 0026659 View Revisions
2017-07-31 12:47 fman Relationship added related to 0008029
2017-08-01 14:14 feremily Note Added: 0026662
2017-08-14 15:29 fman Relationship added duplicate of 0008015
2017-08-14 15:30 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2017-08-14 15:30 fman Summary When trying to execute a test plan the steps are not displayed and no radio buttons => When trying to execute a test plan the steps are not displayed and no radio buttons (PHP 7.1.x version issue)
2017-08-14 15:30 fman Fixed in Version => 1.9.17 (2018 Q1)
2017-08-14 15:30 fman Relationship added child of 0007817
2017-08-14 15:31 fman Status new => resolved
2017-08-14 15:31 fman Resolution open => fixed
2017-08-14 15:31 fman Assigned To => fman
2017-08-14 15:38 feremily Note Added: 0026703
2017-08-14 15:59 fman Relationship deleted related to 0008029
2017-08-14 16:02 fman Note Added: 0026706
2017-08-14 17:41 feremily Note Added: 0026711
2017-08-15 08:20 fman Note Added: 0026713
2017-08-15 15:05 feremily Note Added: 0026716
2017-08-15 15:40 fman Note Added: 0026717
2017-08-18 16:52 fman Relationship added related to 0008054
2017-08-18 17:15 fman Relationship added related to 0007967
2018-04-14 09:04 fman Note Added: 0027319
2018-04-14 09:04 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker