Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007950TestLinkBug Tracking System - JIRA Integrationpublic2017-05-29 06:502018-04-14 09:04
Reportermounika.p@qwikcilver.com 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.16 (2016 Q4) 
Fixed in Version1.9.17 (2018 Q1) 
Summary0007950: The Jira issues updated with Jira integration User name instead of the actual testlink user name
DescriptionWe are using Testlink v 1.9.16.
And find this issue:
1.When create a bug from testlink, the reporter name is the username picked up from the JIra integration username and not the Testlink username.
2.Checked with few issues on the forum but not able to get to the bottom of the solving the issue.
3.The Testlink user is having the permission to edit the reporter in the project.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version7.0.19
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
duplicate of 0007929closedfman Create issue from testlink use wrong username: integration user instead current user 

-  Notes
(0026412)
fman (administrator)
2017-05-29 18:44

Please check for similar issues before reporting.
This issue has been reported and fixed on NEXT RELEASE (1.9.17)
(0026413)
mounika.p@qwikcilver.com (reporter)
2017-05-30 09:59

But we had referred to few of the issues and found out that this bug has been fixed in the version 1.9.16 please look into this: http://mantis.testlink.org/view.php?id=7757 [^]

And also found the recent code change you referred in this link : https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a281fec0d3e7c161d752560121af5eaa0efb47ed [^]

We also tried to get the new version 1.9.17 but unable to find it online.

So can you please guide us on this.
(0026426)
mounika.p@qwikcilver.com (reporter)
2017-06-01 12:40

Hi,

I guess if I would rephrase our issue it would be better for our understanding.

1.We are trying to integrate TestLink v1.9.16 with Jira cloud, and the issue that we are coming face to face with is that the user credentials being used by the API calls to authenticate the user are the ones which belong to the Jira administrator.

2.The API client which POSTs data to Jira cloud uses the Issue tracker configuration file's username-password to authenticate the api calls made from TestLink to Jira cloud, and this is the user details which jira picks while posting the comments . Currently on TL whenever the API calls are being made, there is no provision in the request payload to accommodate the logged in user credentials.

3.We have looked into similar issues and tried out by using the same credentials of the user in the Jira and Testlink.

4.Tried out the latest code change available in this link.https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a281fec0d3e7c161d752560121af5eaa0efb47ed [^]

5.Can we have a call with you so that we can nail it down very quickly and we are pretty sure where we have to make changes.
(0026428)
fman (administrator)
2017-06-01 12:56

For latest code use => https://github.com/TestLinkOpenSourceTRMS/testlink-code/archive/testlink_1_9.zip [^]

As already stated personlized support can be provided only if payed for it => a call means personalized support.
(0026431)
mounika.p@qwikcilver.com (reporter)
2017-06-01 13:19

Hi Francisco,

Thank you for quick response and link to the github location.

We are in the process of doing the POC implementation. It would be great if you can share which module has this fix/where what to look (Test Link and Jira communication). This would help in debugging this issue further.

When the problem get resolved, we would love give back the update to community.

Thank you,
Mounika
(0026436)
fman (administrator)
2017-06-01 18:20

Best option is to install https://github.com/TestLinkOpenSourceTRMS/testlink-code/archive/testlink_1_9.zip [^] .

This code will be 1.9.17 when released. I've fixed issue that was created by some typo error.
This will create issue with logged user in TestLink, if both systems have same username.

Due to JIRA API limitations: if you add notes/comments, owner will be always the user USED TO CONNECT BOTH SYSTEM and not user logged on testlink.
(0027328)
fman (administrator)
2018-04-14 09:04

release 1.9.17

- Issue History
Date Modified Username Field Change
2017-05-29 06:50 mounika.p@qwikcilver.com New Issue
2017-05-29 18:44 fman Note Added: 0026412
2017-05-29 18:45 fman Relationship added duplicate of 0007929
2017-05-29 18:45 fman QA Team - Task Workflow Status => READY FOR TESTING
2017-05-29 18:45 fman Status new => resolved
2017-05-29 18:45 fman Fixed in Version => 1.9.17 (2018 Q1)
2017-05-29 18:45 fman Resolution open => fixed
2017-05-29 18:45 fman Assigned To => fman
2017-05-29 18:46 fman Product Version => 1.9.16 (2016 Q4)
2017-05-30 09:59 mounika.p@qwikcilver.com Note Added: 0026413
2017-06-01 12:40 mounika.p@qwikcilver.com Note Added: 0026426
2017-06-01 12:56 fman Note Added: 0026428
2017-06-01 13:19 mounika.p@qwikcilver.com Note Added: 0026431
2017-06-01 18:20 fman Note Added: 0026436
2018-04-14 09:04 fman Note Added: 0027328
2018-04-14 09:04 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker