Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007943TestLinkInstallerpublic2017-05-19 10:192017-05-19 10:50
Reporterjobou 
Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusnewResolutionopen 
PlatformOSDebianOS Versionjessie
Product Version1.9.16 (2016 Q4) 
Fixed in Version 
Summary0007943: Unable to install mysql schema on mysql 5.5
DescriptionWhen I try to create the Mysql schema, I get this error :

ERROR 1293 (HY000) at line 239: Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause

It seems that you are not supporting MySQL 5.5
Steps To Reproducemysql -u root testlink < install/sql/mysql/testlink_create_tables.sql
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.5
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0026390)
hughkay (reporter)
2017-05-19 10:43

The same issue occured for me when I was upgrading Testlink to version 1.9.15 last year.
TestLink requires MySQL >=5.6 since version 1.9.15.
You'll have to update your MySQL version accordingly or use TestLink with version <= 1.9.14.
(0026391)
jobou (reporter)
2017-05-19 10:50

Ok Thank you.
I did not see the mention about the new mysql requirement in the documentation.

- Issue History
Date Modified Username Field Change
2017-05-19 10:19 jobou New Issue
2017-05-19 10:43 hughkay Note Added: 0026390
2017-05-19 10:50 jobou Note Added: 0026391



Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker