Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007934TestLinkCustom fields ON FILTERSpublic2017-05-07 09:192017-05-31 17:08
Reporterasishgupta 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version 
Summary0007934: Filter Option in Navigator - Requirement Specifications not working
DescriptionWhen filtering the Requirements using "Navigator - Requirement Specifications" based on any field values may be custom field or system field , after pressing the "Apply Button" , no requirement is shown in the tree i.e., in the results pane zero is shown , though there are Requirements based on the value of the field given .

 When the 'Search Requirements' option is selected , then the Requirement is filtered correctly but here Only 1 custom field alongwith its value can be provided. Suppose list of Requirements based on multiple custom field is required , then that cannot be done here .

Plz guide/suggest.

Regards,
ASISH KUMAR GUPTA
Steps To ReproduceAlways
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserAny browser
PHP VersionPHP version: 5.5.35
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesgif file icon filter_notWorking.gif [^] (52,971 bytes) 2017-05-15 10:13

- Relationships

-  Notes
(0026339)
fman (administrator)
2017-05-08 12:35
edited on: 2017-05-08 12:35

1. get latest stable code (1.9.16)
2. do fresh install, retest & provide feedback

Detailed steps to reproduce are needed, and have not been provided

(0026340)
asishgupta (reporter)
2017-05-08 12:48

Hi,
Already projects are defined in TestLink1.9.14. How to migrate the same to TestLink1.9.16 with minimal effort using XAMPP.

I will share the detailed steps to reproduce soon .

Thank You.
ASISH KUMAR GUPTA
(0026341)
fman (administrator)
2017-05-08 16:04

Dear user:
please do fresh install for testing, for migration => see README on testlink install
(0026359)
asishgupta (reporter)
2017-05-15 10:13

Hi,
When filtering the Requirements using "Navigator - Requirement Specifications" based on any field values may be custom field or system field , after pressing the "Apply Button" , no requirement is shown in the tree i.e., in the results pane zero is shown , though there are Requirements based on the value of the field given .

 When the 'Search Requirements' option is selected , then the Requirement is filtered correctly but here Only 1 custom field alongwith its value can be provided. Suppose list of Requirements based on multiple custom field is required , then that cannot be done here .

I am unable to attach file to this case .
Plz let me know if this is a product bug & will be removed if testlink 1.9.16 is used.
Regards,
ASISH KUMAR GUPTA
(0026360)
asishgupta (reporter)
2017-05-15 10:14

eg:
I have uploaded an sttachment .
As seen in the attachment
If BR_complexity as H , BR_platform as System then after pressing Apply button no requirement is filtered though there are requirements matching the criteria.

Plz let me know if this is a product bug & will be removed if testlink 1.9.16 is used.
Regards,
ASISH KUMAR GUPTA
(0026409)
fman (administrator)
2017-05-27 17:41

Tested Filtering by custom fields on 'Requirements Specification' feature, using latest code from github => worked ok
(0026421)
fman (administrator)
2017-05-31 17:08

no more user feedback

- Issue History
Date Modified Username Field Change
2017-05-07 09:19 asishgupta New Issue
2017-05-08 12:35 fman Note Added: 0026339
2017-05-08 12:35 fman Note Edited: 0026339 View Revisions
2017-05-08 12:48 asishgupta Note Added: 0026340
2017-05-08 16:04 fman Note Added: 0026341
2017-05-15 10:13 asishgupta Note Added: 0026359
2017-05-15 10:13 asishgupta File Added: filter_notWorking.gif
2017-05-15 10:14 asishgupta Note Added: 0026360
2017-05-27 17:41 fman Note Added: 0026409
2017-05-27 17:41 fman Assigned To => fman
2017-05-27 17:41 fman Status new => feedback
2017-05-31 17:08 fman QA Team - Task Workflow Status => TBD
2017-05-31 17:08 fman Note Added: 0026421
2017-05-31 17:08 fman Status feedback => closed
2017-05-31 17:08 fman Resolution open => unable to reproduce



Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker