Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007793TestLinkTest Specificationpublic2016-12-22 14:102017-01-22 08:06
ReporterabIng 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007793: Pressing 'Sort alphabetically' button generates errors in log
DescriptionWhenever I press 'Sort alphabetically' button there is no effect, and the log contains the following error messages:
[>>][585bdd45dd260802374003][DEFAULT][/testlink-AB/lib/testcases/containerEdit.php][16/Dec/22 14:03:49]
    [16/Dec/22 14:03:49][ERROR][8hc0e067dc84pev7h8cegm5lk2][AB]
        containerEdit.php.::reorder_testsuites_alpha
    [16/Dec/22 14:03:49][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$direct_link - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 44
    [16/Dec/22 14:03:49][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$direct_link - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 45
    [16/Dec/22 14:03:49][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$form_token - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 54
    [16/Dec/22 14:03:49][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$form_token - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 124
    [16/Dec/22 14:03:49][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$form_token - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 136
    [16/Dec/22 14:03:49][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$form_token - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 161
Steps To Reproduce- Goto Test specification
- On left side choose any test suite containing test cases
- On the top menu of the right side press 'Sort alphabetically' button
- On left side it has no effect
- The log file contains error messages
Additional InformationThe issue is found while studying the issue 7771.
The problem appears in any environment, for example, the environment of 7771 can be used to reproduce
TagsNo tags attached.
Database (MySQL,Postgres,etc)MS SQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0025770)
fman (administrator)
2016-12-22 19:39

Sort Alphabetically is in the group of testsuite operations and it's actions is to sort ONLY test suites (not test cases) by name.
(0025775)
fman (administrator)
2016-12-22 20:05

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/824c18fda986d5097373c0169ec13236d9e067c1 [^]
(0025776)
fman (administrator)
2016-12-22 20:06

please get latest code from github, do fresh install, retest and provide feedback
(0025801)
abIng (reporter)
2016-12-27 10:18

Here is my feedback:
- I use 19.14, I did not install 1.9.15, thus I made modifications manually in the files lib/functions/testproject.class.php and lib/testcases/containerEdit.php
- Now pressing Sort button works - the test suites are reordered as expected
- When pressing the Sort button sometimes there is no error messages in log, but sometimes there are errors
- When there are error messages there are only 2 (instead of 6 that was always the case before modifications)
- The error messages are:
    [16/Dec/27 10:14:42][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$direct_link - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 44
    [16/Dec/27 10:14:42][WARNING][8hc0e067dc84pev7h8cegm5lk2][GUI]
        E_NOTICE
Undefined property: stdClass::$direct_link - in D:\Web\testlink-AB\gui\templates_c\ac6f7ddffb3f95c7298e52cf589cb0911417c0ca.file.containerViewTestSuiteTextButtons.inc.tpl.php - Line 45
(0025802)
fman (administrator)
2016-12-27 11:06

HI
Errors present on 1.9.14 that are not present on latest code from github, are not considered.
(0025883)
fman (administrator)
2017-01-22 08:06

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-12-22 14:10 abIng New Issue
2016-12-22 19:39 fman QA Team - Task Workflow Status => TBD
2016-12-22 19:39 fman Note Added: 0025770
2016-12-22 19:39 fman Assigned To => fman
2016-12-22 19:39 fman Status new => assigned
2016-12-22 20:05 fman Note Added: 0025775
2016-12-22 20:05 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-12-22 20:06 fman Note Added: 0025776
2016-12-22 20:06 fman Status assigned => feedback
2016-12-27 10:18 abIng Note Added: 0025801
2016-12-27 10:18 abIng Status feedback => assigned
2016-12-27 11:06 fman Note Added: 0025802
2016-12-27 11:07 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2016-12-27 11:07 fman Status assigned => resolved
2016-12-27 11:07 fman Resolution open => fixed
2017-01-22 08:06 fman Note Added: 0025883
2017-01-22 08:06 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker