Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007778TestLinkReports - Test report matrixpublic2016-12-07 11:202017-09-13 13:49
ReporterPavlik 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0007778: "Last build" for an unexecuted test case should be an opened one
DescriptionStarting position:
We have several builds, but only the last one is opened. Although all builds are active (due to test reports).
All another builds are already closed.
Due to an internal test rule we don't have to test all test cases in the last build, but only those test cases, which are not passed by the last execution.

Current state:
A mouse click on the green gear (s. active_01.png) at the last build column will induce the opening of the first build, which is already closed (s. active_02.png).


Requested state:
A mouse click on the green gear (s. active_01.png) at the last build column should induce the opening of the one of the opened builds (preferentially the last opened build).
In that case it will be possible for the tester to set the state to passed or failed directly (s. active_03.png).
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon active_01.PNG [^] (27,290 bytes) 2016-12-07 11:20


png file icon active_02.PNG [^] (28,527 bytes) 2016-12-07 11:20


png file icon active_03.PNG [^] (42,517 bytes) 2016-12-07 11:21

- Relationships

-  Notes
(0025686)
fman (administrator)
2016-12-07 15:45

You said that you need to retest TEST NOT PASSED ON LASTEST EXECUTION, and this column is present on report, then it's not clear why you want to use LAST BUILD Column.

In addition your explanation about use you do on ACTIVE, OPEN and closed build is far from clear.
If you can write a simple example with 3 builds it will be great to try to understand if this can be a new feature or will be rejected.
(0025774)
fman (administrator)
2016-12-22 19:42

any news regarding my request?
(0025842)
fman (administrator)
2017-01-14 18:06

no more user feedback
(0026836)
Pavlik (reporter)
2017-09-13 13:49

I´ll try.

1. Build nr. 1 is deployed. We have 10 test cases. Testers test test cases nr. 5,6 and 7. 5 and 6 are passed, 7 is failed.

2. Developers correct the program. Build nr. 1 is closed. Build nr. 2 is deployed. Tester test test case nr. 7. This test case is passed now. The testers continue the test with test cases 1,2 and 3. 1 and 2 are passed. Test case nr. 3 is failed.

3. Developers correct the program. Build nr. 2 is closed. Build nr. 3 is deployed. Tester test the test case 3 now. It is passed now. Then the testers want to now, which test cases are not passed at all and test this test cases. In my example they are test cases nr. 4,8,9 and 10.

What is the easiest way for testers to find out, which test cases are not passed at last execution and to test this test cases?
A favourite way for testers would be to see at the "test execution" in the test case tree the colour marking for the last execution for all test cases. Then the would be execute all test cases, which are not "green".

If this tester´s favourite way is not possible, then a second favourite way would be to start the test execution input form for every not green test case from the test result table ("Results of Test Cases for all Builds") by clicking on the "wheel" at the last column ("last execution") also for "not executed" test cases (s. active_01.PNG).

I hope, You would understand it now. Sorry for my English :-(

- Issue History
Date Modified Username Field Change
2016-12-07 11:20 Pavlik New Issue
2016-12-07 11:20 Pavlik File Added: active_01.PNG
2016-12-07 11:20 Pavlik File Added: active_02.PNG
2016-12-07 11:21 Pavlik File Added: active_03.PNG
2016-12-07 15:45 fman Note Added: 0025686
2016-12-07 15:52 fman Assigned To => fman
2016-12-07 15:52 fman Status new => feedback
2016-12-22 19:42 fman Note Added: 0025774
2017-01-14 18:06 fman QA Team - Task Workflow Status => TBD
2017-01-14 18:06 fman Note Added: 0025842
2017-01-14 18:06 fman Status feedback => closed
2017-01-14 18:06 fman Resolution open => unable to reproduce
2017-09-13 13:49 Pavlik Note Added: 0026836
2017-09-13 13:49 Pavlik Status closed => assigned
2017-09-13 13:49 Pavlik Resolution unable to reproduce => reopened



Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker