Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007756TestLinkBug Tracking System - Redmine Integrationpublic2016-11-22 08:452017-01-22 07:57
Reportersepecho 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.15 (2015 Q4) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007756: Unable to link created/existing issue from Redmine to TestLink
DescriptionCannot link a created and existing issue from Redmine to TestLink.

The following errors I encounter are the following:
1. Bug ID does not exist on BTS!
2. Wrong Bug ID format!
3. Create REDMINE Ticket FAILURE => Error Calling redminerestInterface->APIClient->addIssueFromXMLString() check Communication TimeOut - serialized issue:N;
Steps To ReproduceFor issue #1:
1. I configured the Issue Tracker Management using this, please refer to attached file: RedminBugTrackerConfig.jpg
2. I executed a failed test case then click on the Link Existent Issue icon under Bug Management.
3. Add Link to Bug Report window pops up.
4. I click on the Access to Bug Tracking System (Redmine Bug Tracker) link.
5. Directed to the Redmine page, create an issue.
6. I go back to the Add Link to Bug Report window to enter the Bug ID of the issue I have created, please refer to: LinkBugID4016
7. Click on the Add Link in Issue Tracker to Test Case Execution Feature check box.
8. Click Save button.
9. I get an error: Bug ID 4016 does not exist on BTS!

For issue 0000002:
1. Do step 0000002 to 0000005 except that I will use the same Bug ID instead of create a new issue.
2. Do step 0000006 but I used a different format to enter the issue number, please refer to: LinkBugID4016differentformat.jpg
3. Click on the Add Link in Issue Tracker to Test Case Execution Feature check box.
4. Click Save button.
5. I get an error: Wrong Bug ID format!

For issue 0000003:
1. Use the Create Issue icon to create an issue thru testlink.
2. Enter the issue summary in the Create Issue pop up window.
3. Do steps 3 to 4 from above.
4. I get an error: Create REDMINE Ticket FAILURE => Error Calling redminerestInterface->APIClient->addIssueFromXMLString() check Communication TimeOut - serialized issue:N;





Additional InformationI don't have any idea on what version of Redmine our company was using but it says below that:

Powered by Bitnami Redmine Stack © 2006-2015 Jean-Philippe Lang
TagsNo tags attached.
Database (MySQL,Postgres,etc)Database that is in the testlink1.9.15 package
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon RedminBugTrackerConfig.PNG [^] (21,181 bytes) 2016-11-22 08:45


jpg file icon LinkBugID4016.JPG [^] (29,169 bytes) 2016-11-22 08:46


jpg file icon LinkBugID4016diferrentformat.JPG [^] (28,200 bytes) 2016-11-22 08:46

- Relationships
related to 0007714closedfman failure to report issue 

-  Notes
(0025634)
nmtuan (reporter)
2016-11-25 06:32

I'm also having this issue using Bitnami TestLink (1.9.15) and Bitnami Redmine (3.3.1)
I've enabled Redmine Rest API, tested via Postman (verified that it works)
Configured Redmine TestLink-BTS like the above description, got the same errors
(0025637)
fman (administrator)
2016-11-26 10:57

Issue is related to saving in _SESSION the issue tracking object, but due to this curl resourse is destroyed.
I will fix soon
(0025639)
fman (administrator)
2016-11-26 11:31

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/933f2fee8e49b242f336e9722366671963b81081 [^]
(0025872)
fman (administrator)
2017-01-22 07:57

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-11-22 08:45 sepecho New Issue
2016-11-22 08:45 sepecho File Added: RedminBugTrackerConfig.PNG
2016-11-22 08:46 sepecho File Added: LinkBugID4016.JPG
2016-11-22 08:46 sepecho File Added: LinkBugID4016diferrentformat.JPG
2016-11-25 06:32 nmtuan Note Added: 0025634
2016-11-26 10:57 fman Note Added: 0025637
2016-11-26 10:57 fman Relationship added related to 0007714
2016-11-26 11:31 fman Note Added: 0025639
2016-11-26 11:32 fman QA Team - Task Workflow Status => TBD
2016-11-26 11:32 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-11-26 11:46 fman Assigned To => fman
2016-11-26 11:46 fman Status new => feedback
2016-12-24 14:52 fman Status feedback => resolved
2016-12-24 14:52 fman Resolution open => fixed
2017-01-22 07:57 fman Note Added: 0025872
2017-01-22 07:57 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker