Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007743TestLinkDatabase MS-SQLpublic2016-11-14 15:512018-10-06 12:17
Reporterbuzzlightyear 
Assigned Tofman 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows 7OSOS Version
Product Version1.9.15 (2015 Q4) 
Fixed in Version1.9.18 (2018 Q3) 
Summary0007743: Unable to deploy on MSSQL 2008 R2
DescriptionDeployment fails because identity column has default clause on the following tables:
*plugins
*plugins_configuration

Removing the default clause causes the deploy to succeed. This is in install\sql\mssql\testlink_create_tables.sql
Steps To ReproduceDeploy to MSSQL database
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
duplicate of 0007680closedfman Bug in MSSQL/testlink_create_tables.sql while creating plugins table  

-  Notes
(0027580)
abIng (reporter)
2018-06-13 12:26

Me also, I have this problem with 1.9.16 as well as with 1.9.17, see http://mantis.testlink.org/view.php?id=7680. [^]
Removing the default clause is not enough.
It works only if constraint clauses are removed, see my comment in 7680.
(0027595)
fman (administrator)
2018-06-16 17:28

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/522352792272801c2df317fc5111ddb88e2273b7 [^]
(0027945)
fman (administrator)
2018-10-06 12:17

1.9.18 released

- Issue History
Date Modified Username Field Change
2016-11-14 15:51 buzzlightyear New Issue
2018-06-13 12:26 abIng Note Added: 0027580
2018-06-16 17:02 fman Relationship added duplicate of 0007680
2018-06-16 17:28 fman Note Added: 0027595
2018-06-16 17:28 fman QA Team - Task Workflow Status => TBD
2018-06-16 17:28 fman Fixed in Version => 1.9.18 (2018 Q3)
2018-06-16 17:29 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2018-06-16 17:29 fman Status new => resolved
2018-06-16 17:29 fman Resolution open => fixed
2018-06-16 17:29 fman Assigned To => fman
2018-10-06 12:17 fman Note Added: 0027945
2018-10-06 12:17 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker