Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007725TestLinkTest Specificationpublic2016-10-27 06:072017-01-22 08:06
Reportermkn_hin 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows-PCOSWindowsOS VersionWindows 7
Product Version1.9.15 (2015 Q4) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007725: Renaming test suite fails
DescriptionRenaming a test suite results in the following error message:

Fatal error: Uncaught Error: Cannot access private property testsuite::$object_table in C:\xampp\htdocs\testlink\lib\testcases\containerEdit.php:1334 Stack trace: #0 C:\xampp\htdocs\testlink\lib\testcases\containerEdit.php(245): initializeGui(Object(testsuite), 111, Object(stdClass), Array) #1 {main} thrown in C:\xampp\htdocs\testlink\lib\testcases\containerEdit.php on line 1334

However, the renaming is done. After reloading the list of test suites, the new name is correctly shown.
Steps To ReproduceSelect "Test Specification" and click on a test suite on the left side.

The test suite is now shown on the right side. Click on the Actions icon and then on the Edit icon.

The "Edit Test Suite" page is shown. Change the test suite name and select "Save" (actually, it is not important to really change the name).

The above error message is now shown.
Additional InformationLooks like this problem was created in git at version c9e96be4 on 2017-09-27
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 49.0.2
PHP VersionPHP 7.0.6 (XAMPP)
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0025544)
fman (administrator)
2016-10-27 19:21

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/da378ea3b165086b52baf03377fabfbba055f170 [^]
(0025889)
fman (administrator)
2017-01-22 08:06

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-10-27 06:07 mkn_hin New Issue
2016-10-27 19:21 fman QA Team - Task Workflow Status => TBD
2016-10-27 19:21 fman Product Version => 1.9.15 (2015 Q4)
2016-10-27 19:21 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-10-27 19:21 fman Note Added: 0025544
2016-10-27 19:22 fman Status new => resolved
2016-10-27 19:22 fman Resolution open => fixed
2016-10-27 19:22 fman Assigned To => fman
2017-01-22 08:06 fman Note Added: 0025889
2017-01-22 08:06 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker