Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007708TestLinkLocalizationpublic2016-10-20 07:392017-01-22 08:08
Reporterwagnerfl 
Assigned Tofman 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWindowsOS Version7 / 10
Product Version1.9.15 (2015 Q4) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007708: PHP Fatal error: Call to undefined function plugin_get_current() in /var/www/testlink/lib/functions/lang_api.php on line 67
DescriptionHi @all,

we are testing Testlink at the moment and on Chrome/Firefox it works well. But when we try to reach Testlink from Windows 7 / 10 with IE, we get an white page an in the error logs from Apache we find the following lines:

PHP Fatal error: Call to undefined function plugin_get_current() in /var/www/testlink/lib/functions/lang_api.php on line 67

Steps To ReproduceIn Internet Explorer set language deutsch [de-DE] under "internet options - Languages" you get this problem, when you switch to deutsch [de] the problem is solved so far.

Same behavior on Edge, but i know you don't support it official.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE 11
PHP VersionPHP 5.5.38 (cli) (built: Jul 21 2016 12:25:20)
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
related to 0007667closedfman Fatal error after Testlink upgrade to 1.9.15 - missing plugin_get_current() 
related to 0007679new loging page can't view when default is zh_ch 

-  Notes
(0025517)
fman (administrator)
2016-10-20 19:05

Please get latest code from github, do fresh install, retest and provide feedback
(0025518)
fman (administrator)
2016-10-20 19:10

Think this can help
https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/db746440924aa3a572c8058a0595a9572cf36979 [^]
(0025524)
wagnerfl (reporter)
2016-10-21 09:31

Seems to work now with the new common.php. Thank you for this very fast solution!
(0025910)
fman (administrator)
2017-01-22 08:08

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-10-20 07:39 wagnerfl New Issue
2016-10-20 19:05 fman Note Added: 0025517
2016-10-20 19:05 fman Assigned To => fman
2016-10-20 19:05 fman Status new => feedback
2016-10-20 19:06 fman Relationship added related to 0007667
2016-10-20 19:07 fman Relationship added related to 0007679
2016-10-20 19:10 fman Note Added: 0025518
2016-10-21 09:31 wagnerfl Note Added: 0025524
2016-10-21 09:31 wagnerfl Status feedback => assigned
2016-10-21 17:02 fman QA Team - Task Workflow Status => TBD
2016-10-21 17:02 fman Status assigned => resolved
2016-10-21 17:02 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-10-21 17:02 fman Resolution open => fixed
2017-01-22 08:08 fman Note Added: 0025910
2017-01-22 08:08 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker