Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007706TestLinkTest Specification Importpublic2016-10-18 07:232017-01-22 08:06
Reporterjaverty 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformRedHatOSRedHatOS Version5.5
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007706: Fail to Import a XML files to update a Testcase executed in a older version
DescriptionI have a test case, that has already been executed in Version 1. The GUI tells me, that I do have permission, to edit it in version 2.
But I can't import a XML files to modify the version 2 because the Testcase "Not updated - Reason: Latest Test Case version has been executed." if the version 2 is Linked (but not executed) to a TestPlan.
Steps To Reproduce* Use a user who have non right to Edit Executed Test Cases
* Create a TestCase
* Record a TestCase execution result
* Create a version 2 of the Testcase
* Update Linked Test Case Versions and add the version 2 of the Testcase
* Try to Edit and Modify that TestCase in the web GUI
-> Operation reports success
* Try to Import a XML files (Test Case Operations) with the options:
- Consider Test Case as duplicate if has same Interface ID
- Action for duplicates Update data in the Latest version

-> Operation reports failed : " Not updated - Reason: Latest Test Case version has been executed."
* re-open that test case in the web GUI
-> Testcase is not changed.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
BrowserFirefox ESR 45.4.0
PHP Version5.4
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon Screen Shot 2016-10-20 at 22.23.02.png [^] (61,436 bytes) 2016-10-20 20:23


xml file icon COCOA-TC-1A.version2.testcase.xml [^] (487 bytes) 2016-10-20 20:35

- Relationships

-  Notes
(0025513)
fman (administrator)
2016-10-19 12:58

Please
get latest stable code, do fresh install, retest and provide feedback
(0025515)
javerty (reporter)
2016-10-20 12:25

I test in 1.9.15.
The problem is still the same.
(0025516)
fman (administrator)
2016-10-20 19:00

Thnaks for your feedback
(0025521)
fman (administrator)
2016-10-20 20:20
edited on: 2016-10-20 20:57

1) Create user pepe with role leader => standard rola that has NO RIGHT TO EDIT executed test cases

2) LOGIN AS ADMIN and Create test project COCOA
3) Create Test Suite TS-100
4) Creata Test Case TC-1A, Version 1
5) Create Test plan TPLAN-A and Build 1.0
6) Add TC-1A version1 to Test Plan TPLAN-A
7) execute it
8) LOG OUT
9) LOGIN as pepe, and go to test spec feature to try to edit TC-1A
10) Try to edit => you will get attached image => pepe can not => it's OK
11) pepe creates a new version
12)pepe LOGOUT
13) LOGIN as ADMIN and update linked version to 2 on test plan
14) LOGOUT
15) Login as pepe, and go to test spec feature to try to edit TC-1A => he can
16)Export test case TC-1A => you will get version 2.
modify xml adding the word something into summary , see attached file
17) Try to import file
18) Error reported is verified !!!

(0025522)
fman (administrator)
2016-10-20 21:03

Please try fix (or better get latest complete code from github), retest and provide feedback

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/e5aedee5e3f7cd1d1ba5af785497b5476aa63b3e [^]
(0025525)
javerty (reporter)
2016-10-21 12:24

The problem is still the same.
I'm not a expert in php, but it's seems that $rs['tcversion_number'] and $rs['version'] are empty.

And if there are more than one execution, $rs will have more than one row :

SELECT EX.id, EX.tcversion_number,TCV.version
FROM tl_executions EX
JOIN tl_tcversions TCV
ON TCV.id = EX.tcversion_id
WHERE tcversion_id=160;
 id | tcversion_number | version
----+------------------+---------
 11 | 4 | 5
  9 | 2 | 5
  2 | 1 | 5
(3 lignes)
(0025527)
fman (administrator)
2016-10-21 16:55

My fault, I've tested with a single execution, I'm going to review implementation.
thanks for your help
(0025531)
fman (administrator)
2016-10-22 08:26

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a571e8a866591febf391e31bfc9165240ea4da74 [^]
(0025535)
javerty (reporter)
2016-10-24 09:29

I've tested, and it's works for me.
Thank you for this fast resolution.
(0025888)
fman (administrator)
2017-01-22 08:06

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-10-18 07:23 javerty New Issue
2016-10-19 12:58 fman Note Added: 0025513
2016-10-19 12:58 fman Assigned To => fman
2016-10-19 12:58 fman Status new => feedback
2016-10-20 12:25 javerty Note Added: 0025515
2016-10-20 12:25 javerty Status feedback => assigned
2016-10-20 19:00 fman Note Added: 0025516
2016-10-20 20:20 fman Note Added: 0025521
2016-10-20 20:23 fman Note Edited: 0025521 View Revisions
2016-10-20 20:23 fman File Added: Screen Shot 2016-10-20 at 22.23.02.png
2016-10-20 20:28 fman Note Edited: 0025521 View Revisions
2016-10-20 20:30 fman Note Edited: 0025521 View Revisions
2016-10-20 20:34 fman Note Edited: 0025521 View Revisions
2016-10-20 20:35 fman File Added: COCOA-TC-1A.version2.testcase.xml
2016-10-20 20:51 fman Note Edited: 0025521 View Revisions
2016-10-20 20:57 fman Note Edited: 0025521 View Revisions
2016-10-20 21:03 fman Note Added: 0025522
2016-10-20 21:04 fman Status assigned => feedback
2016-10-20 21:04 fman QA Team - Task Workflow Status => TBD
2016-10-21 12:24 javerty Note Added: 0025525
2016-10-21 12:24 javerty Status feedback => assigned
2016-10-21 16:55 fman Note Added: 0025527
2016-10-22 08:26 fman Note Added: 0025531
2016-10-24 09:29 javerty Note Added: 0025535
2016-10-27 19:33 fman Status assigned => resolved
2016-10-27 19:33 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-10-27 19:33 fman Resolution open => fixed
2017-01-22 08:06 fman Note Added: 0025888
2017-01-22 08:06 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker