Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007676TestLinkGUIpublic2016-09-16 12:542017-01-22 07:57
Reporterpepamdf 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS VersionWin 7 Profession
Product Version1.9.15 (2015 Q4) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007676: Password reset does not work
DescriptionWhen I try to reset my password, I get an Email with the new password, but this does not work. When I look in the database the password entry is NOT changed !
The same happens, when I click at "Forgot Password" at the Login Screen.

It seems that the database is not updated after calculating and sending the new password.

Whereas if i change my password by myself in my settings, the database is changed immediately.

I've used the "Reset Pasword" button in a user in the User Administration.
I've received the email with the new pasword, but when I try to log in with the new password, it does not work . I receive "Try again! Wrong login name or password!".

Steps To Reproduce1- Create User, by clicking the "New User?"
Ps. This User was created in LDAP as the method was active in php.ini
2- Method LDAP commented again in php.ini and authentication code in config.ini.php returned to default.
3- Reset the User Password created by the button "Lost Password?"
4- After receiving email, try to login with the new password
5- BUG: New password does not work. Message displayed => Try again! Wrong login name or password!
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.2
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
related to 0007814closedfman Unable to Reset Passwords For Users with DB Authentication In System Using Mixed LDAP/DB Authentication 
has duplicate 0007702closedfman User cannot login with a new password from an email after reseting the password by admin 
related to 0007677closedfman Unable to login after resetting password 
child of 0007666closedfman Availables hot-fixes for 1.9.15 & How To get full fixed package from GitHub 

-  Notes
(0025417)
fman (administrator)
2016-09-17 06:55

if user is created with LDAP DB, then change password will never work.
TestLink does not use php.ini then this
>> This User was created in LDAP as the method was active in php.ini
has no effect on testlink.

your detailed steps to reproduce are incomplete because you do not provide full details of user configuration.
without this infor no action can be done
(0025423)
daronz (reporter)
2016-09-18 08:54

Hi, I have a same problem, but the user was not created in LDAP. When I clicked the reset password button, I found that the password was not changed in the database.
(0025424)
daronz (reporter)
2016-09-18 09:10

@fman Under the same conditions, TestLink 1.9.14 works well.
(0025425)
fman (administrator)
2016-09-18 09:36

@daronz: ok with this additional info I'm going to check.
Thanks
(0025426)
fman (administrator)
2016-09-18 10:06

Fix
https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/adc1a681266faa7f4c476d6442f033be3622ab27 [^]
(0025428)
pepamdf (reporter)
2016-09-19 16:48

Files substituted.
The system behaved correctly.
Retest OK.
(0025861)
fman (administrator)
2017-01-22 07:57

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-09-16 12:54 pepamdf New Issue
2016-09-17 06:55 fman Note Added: 0025417
2016-09-17 06:55 fman Assigned To => fman
2016-09-17 06:55 fman Status new => feedback
2016-09-18 08:47 fman Relationship added related to 0007677
2016-09-18 08:54 daronz Note Added: 0025423
2016-09-18 09:10 daronz Note Added: 0025424
2016-09-18 09:36 fman Note Added: 0025425
2016-09-18 09:37 fman QA Team - Task Workflow Status => TBD
2016-09-18 09:37 fman Description Updated View Revisions
2016-09-18 09:44 fman Relationship added child of 0007666
2016-09-18 09:44 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-09-18 10:06 fman Note Added: 0025426
2016-09-19 16:48 pepamdf Note Added: 0025428
2016-09-19 16:48 pepamdf Status feedback => assigned
2016-09-19 20:28 fman Status assigned => resolved
2016-09-19 20:28 fman Resolution open => fixed
2016-10-17 18:45 fman Relationship added has duplicate 0007702
2017-01-19 20:16 fman Relationship added related to 0007814
2017-01-22 07:57 fman Note Added: 0025861
2017-01-22 07:57 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker