Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007638TestLinkTest Plan - Assign Test Case Executionpublic2016-08-15 08:492017-01-22 08:06
Reporterbigd 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.16 (2016 Q4) 
Summary0007638: No mail notification when removing test case assignment
DescriptionWhen removing a testers test case assignment on the page "Assign Test Case Execution" (/testlink/lib/general/frmWorkArea.php?feature=tc_exec_assignment) using the "remove" icon (0006516), no email notification is sent to the tester.
This is regardless of the value of the checkbox "Send mail notification to tester".
Steps To Reproduce1. Goto the page "Assign Test Case Execution"
2. Assign a test case to tester A.
3. Remove the test case assignment from tester A by using the "remove" icon (0006516).
Additional InformationNot getting a notification when a test case is reassigned sometimes leads to us having 2 testers running the same test case, since the original assignee might not have updated his list of assigned test cases in the browser.
This is particularly problematic when we get close to deadlines, since we often need to redistribute the remaining test case executions among the testers at that point.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0007666closedfman Availables hot-fixes for 1.9.15 & How To get full fixed package from GitHub 

-  Notes
(0025119)
fman (administrator)
2016-08-15 19:12

1) To help dev team work, please get latest code from github, do a fresh install, retest and provide feedback.

2) Regarding what has been written on additional information:
>> Not getting a notification when a test case is reassigned sometimes leads to us having 2
>> testers running the same test case, since the original assignee might not have updated his list
>>of assigned test cases in the browser.
>> This is particularly problematic when we get close to deadlines, since we often need to
>> redistribute the remaining test case executions among the testers at that point.

Well I disagree.
IMHO no system can solve issues regarding how people work.
IMHO I've same warranty that people read his/her email, than people update his/her list => none.
I will be very worried if people working with me said '... oh man, because I've not got any mail I've done no check ...'.

IMHO if issue exists, I can work (no ETA) to fix it.
(0025178)
fman (administrator)
2016-09-03 16:26

no more user feedback
(0025190)
bigd (reporter)
2016-09-07 13:16

Sorry for the late reply - I didnt check my email... :-)
(Actually, it's because I'm using my secondary email account here since the spam filter at my office rejected the account verification emails when I first registered...).

I see your point, fman, but email notifications when test case assignments are removed gives the tester a heads up that will make him refresh his list of "test cases assigned to me". This also gives the tester a chance to say to the test leader "hey, hold it! I've already started on that one!".

The alternative would be that testers always refreshed their list of assigned test cases before starting each and every tc execution. Of course, the test leader could instruct testers to do so, but it would be less than optimal. They way it worked before was so much better...

I've tried workarounds as using the "bulk user remove" function and the "Add/remove test cases" function (by first removing the TC and then adding it again), but none of the functions sends email notifications when removing test cases or execution assignment.
(0025192)
fman (administrator)
2016-09-07 17:00

Please confirm that you have done as suggested i.e.

1) To help dev team work, please get latest code from github, do a fresh install, retest and provide feedback.

this information is critic
(0025400)
bigd (reporter)
2016-09-13 10:10

I did a fresh install using version 1.9.15 downloaded from github and was able to reproduce the issue.
(0025429)
fman (administrator)
2016-09-19 20:30

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/eebbadc56652fba2096115a625c3a5253c5283f5 [^]
(0025893)
fman (administrator)
2017-01-22 08:06

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-08-15 08:49 bigd New Issue
2016-08-15 19:12 fman Note Added: 0025119
2016-08-15 19:12 fman Assigned To => fman
2016-08-15 19:12 fman Status new => feedback
2016-09-03 16:26 fman QA Team - Task Workflow Status => TBD
2016-09-03 16:26 fman Note Added: 0025178
2016-09-03 16:26 fman Status feedback => closed
2016-09-03 16:26 fman Resolution open => unable to reproduce
2016-09-07 13:16 bigd Note Added: 0025190
2016-09-07 13:16 bigd Status closed => assigned
2016-09-07 13:16 bigd Resolution unable to reproduce => reopened
2016-09-07 17:00 fman Note Added: 0025192
2016-09-07 17:00 fman Status assigned => feedback
2016-09-13 10:10 bigd Note Added: 0025400
2016-09-13 10:10 bigd Status feedback => assigned
2016-09-19 20:30 fman Note Added: 0025429
2016-09-19 20:30 fman Fixed in Version => 1.9.16 (2016 Q4)
2016-09-19 20:30 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2016-09-19 20:30 fman Status assigned => resolved
2016-09-19 20:30 fman Resolution reopened => fixed
2016-09-19 20:31 fman Relationship added child of 0007666
2017-01-22 08:06 fman Note Added: 0025893
2017-01-22 08:06 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker