Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007625TestLinkAssign Test Case Executionpublic2016-07-14 21:182017-01-22 07:57
Reportermens_tester 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007625: Email notification sent to User does not contain Platform and Build
DescriptionWe are using Platforms
Additionally we do have typically 2 builds active (one for debug and one for release build)

User must select the correct Platform and Build in selection boxes but does not know it - so its trial and error through all possibilities.
Steps To ReproduceGo To the assignment Page select a Platform and a build and assign all of the Testcases to one user.

The User receives a mail with:

-->
Test Project: TestPrj
Test Plan: R1.1.1

Following Test Cases has been assigned to you Tester by Admin

Project/Suite/Case01
Project/Suite/Case02
Project/Suite/Case03
Project/Suite/Case04
Project/Suite/Case05
<---

Additional InformationIt would help if there would be following additional information:

-->
Test Project: TestPrj
Test Plan: R1.1.1
Test Build: r19999

Following Test Cases has been assigned to you Tester by Admin

Platform: Firefox
Project/Suite/Case01
Project/Suite/Case02
Project/Suite/Case03

Platform: Internet Explorer
Project/Suite/Case04
Project/Suite/Case05
<---
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0007627closedfman Test Plan Add/remove Test cases - Email notification sent to User does not contain Platform and Build 
child of 0007262closedfman Availables hot-fixes for 1.9.14 & How To get full fixed package from GitHub 

-  Notes
(0025081)
fman (administrator)
2016-07-15 06:17

>> User must select the correct Platform and Build in selection boxes but does not know it - so its trial and error through all possibilities.

IMHO this is not through because filter to filter 'ASSIGNED TO ME' is provided in several features

A better details to undertand on what feature user has this issue is mandatory.
(0025084)
mens_tester (reporter)
2016-07-16 11:08

Execute Page

In the Settings dialog (top left) Platform and Build must be selected.
The Filter dialog (below Settings dialog) does have the possibility to search for assigned to "User" on "ALL builds" but you will get only the result for the selected Platform in the Settings dialog.

The user has to walk through all platforms using this approach.
(0025085)
fman (administrator)
2016-07-16 15:57

>> does have the possibility to search for assigned to "User" on "ALL builds"
this is right, because filter for assigned is intended to be used to be used when user is going to execute, and user can execute only on one build at a time.
(0025086)
fman (administrator)
2016-07-17 08:13

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/83f9a3115cf3bdde82cde61d6e67090300122cf0 [^]
(0025106)
fman (administrator)
2016-07-28 20:51

It would be really great to get some feedback from reporter
(0025208)
fman (administrator)
2016-09-08 15:12

1.9.15 Released - 2016-09-08
(0025640)
mens_tester (reporter)
2016-11-26 11:59

Thank you for trying to solve this find below a sample E-mail sent by 1.9.15 Problem discovered is that only the first character of the Platform name is described in the email content:

We have Platforms with names like TP111,TP112 as you can see below the tester does not know which Platform is assigned.


Test Project: MyProject
Test Plan: MYPLAN
Build: MYBUILD

Following Test Cases has been assigned to you .... by .....


Platform: T
SUITE1/MPR-4998 first test
http://test2/testlink/linkto.php?tprojectPrefix=MPR&item=testcase&id=MPR-4998 [^]
(0025642)
fman (administrator)
2016-11-26 15:33

just tested with latest code from github (will be 1.9.16) => works OK.
(0025871)
fman (administrator)
2017-01-22 07:57

1.9.16 released

- Issue History
Date Modified Username Field Change
2016-07-14 21:18 mens_tester New Issue
2016-07-15 06:17 fman Note Added: 0025081
2016-07-15 06:17 fman Status new => feedback
2016-07-16 11:08 mens_tester Note Added: 0025084
2016-07-16 11:08 mens_tester Status feedback => new
2016-07-16 15:57 fman Note Added: 0025085
2016-07-17 08:11 fman QA Team - Task Workflow Status => TBD
2016-07-17 08:11 fman Summary Email notification sent to User does not contaion Platform and Build => Email notification sent to User does not contain Platform and Build
2016-07-17 08:13 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2016-07-17 08:13 fman Note Added: 0025086
2016-07-17 08:13 fman Status new => resolved
2016-07-17 08:13 fman Fixed in Version => 1.9.15 (2015 Q4)
2016-07-17 08:13 fman Resolution open => fixed
2016-07-17 08:13 fman Assigned To => fman
2016-07-17 08:14 fman Relationship added child of 0007262
2016-07-17 08:20 fman Issue cloned: 0007627
2016-07-17 08:20 fman Relationship added related to 0007627
2016-07-28 20:51 fman Note Added: 0025106
2016-09-08 15:12 fman Note Added: 0025208
2016-09-08 15:12 fman Status resolved => closed
2016-11-26 11:59 mens_tester Note Added: 0025640
2016-11-26 11:59 mens_tester Status closed => assigned
2016-11-26 11:59 mens_tester Resolution fixed => reopened
2016-11-26 15:33 fman Note Added: 0025642
2016-11-26 15:33 fman Status assigned => feedback
2016-12-24 14:53 fman Status feedback => resolved
2016-12-24 14:53 fman Resolution reopened => fixed
2017-01-22 07:57 fman Note Added: 0025871
2017-01-22 07:57 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker