Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007528TestLinkDatabase MySQLpublic2016-05-03 03:552016-09-08 15:12
Reporterericli 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.15 (2015 Q4) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007528: Missing creationsof two new tables for MySQL in alter_tables
DescriptionFollowing two tables can be found in newly installation file:
testlink_create_tables.sql

However, cannot find in the upgrade package under \alter_tables folder:
db_schema_update.sql

CREATE TABLE /*prefix*/req_notify_assignments (
  `id` int(10) NOT NULL AUTO_INCREMENT,
  `testproject_id` int(11) NOT NULL,
  `field_id` int(10) NOT NULL,
  `field_value` varchar(64) NOT NULL,
  `assigned_user_id` int(10) NOT NULL,
  PRIMARY KEY (`id`)
) AUTO_INCREMENT=1 DEFAULT CHARSET=utf8;

CREATE TABLE /*prefix*/req_monitor (
  `req_id` int(11) NOT NULL,
  `user_id` int(11) NOT NULL,
  `testproject_id` int(11) NOT NULL,
  PRIMARY KEY (`req_id`,`user_id`)
) DEFAULT CHARSET=utf8;
Steps To ReproduceWithout those two tables, access to "requirement" got database error messages
Additional InformationCannot found in alter_tables folder since DB1.9.11
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5.4
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0007262closedfman Availables hot-fixes for 1.9.14 & How To get full fixed package from GitHub 

-  Notes
(0025248)
fman (administrator)
2016-09-08 15:12

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2016-05-03 03:55 ericli New Issue
2016-05-07 08:31 fman QA Team - Task Workflow Status => TBD
2016-05-07 08:31 fman Product Version 1.9.14 (2015 Q3) => 1.9.15 (2015 Q4)
2016-05-07 08:31 fman Fixed in Version => 1.9.15 (2015 Q4)
2016-05-07 08:32 fman Relationship added child of 0007262
2016-05-07 08:32 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2016-05-07 08:32 fman Status new => resolved
2016-05-07 08:32 fman Resolution open => fixed
2016-05-07 08:32 fman Assigned To => fman
2016-09-08 15:12 fman Note Added: 0025248
2016-09-08 15:12 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker