Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007519TestLinkTest Specification Importpublic2016-04-22 10:302016-09-08 15:12
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007519: Import TestCases activation and frozen status from XML content
Description<active> and <is_open> tags are now present in XML export (see 0007516 and 0007517).

Attached modification allows testlink to import XML file that present the same tags to create / update Testcases content.
Additional InformationI'm not a developper, I have adapted code used for <status> tag.
I hope that help
TagsNo tags attached.
Database (MySQL,Postgres,etc)All
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon tcImport-before.php [^] (35,504 bytes) 2016-04-22 10:30
? file icon testcase.class-before.php [^] (258,399 bytes) 2016-04-22 10:31
? file icon tcImport-after.php [^] (35,719 bytes) 2016-04-22 10:31
? file icon testcase.class-after.php [^] (258,991 bytes) 2016-04-22 10:31

- Relationships
child of 0007262closedfman Availables hot-fixes for 1.9.14 & How To get full fixed package from GitHub 

-  Notes
(0024736)
fman (administrator)
2016-04-22 15:37

Thanks a lot, I'm going to review the code
(0024822)
Mr.Bricodage (updater)
2016-05-13 15:19
edited on: 2016-07-02 07:50

GITBHU PULL REQUEST 21 : https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/21 [^]

(0025013)
Mr.Bricodage (updater)
2016-06-23 14:17

Issue should be marked as resolved since PR has been merged.
(0025220)
fman (administrator)
2016-09-08 15:12

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2016-04-22 10:30 Mr.Bricodage New Issue
2016-04-22 10:30 Mr.Bricodage File Added: tcImport-before.php
2016-04-22 10:31 Mr.Bricodage File Added: testcase.class-before.php
2016-04-22 10:31 Mr.Bricodage File Added: tcImport-after.php
2016-04-22 10:31 Mr.Bricodage File Added: testcase.class-after.php
2016-04-22 15:37 fman Note Added: 0024736
2016-05-13 15:19 Mr.Bricodage Note Added: 0024822
2016-06-23 14:17 Mr.Bricodage Note Added: 0025013
2016-07-02 07:50 fman Note Edited: 0024822 View Revisions
2016-07-02 07:51 fman QA Team - Task Workflow Status => READY FOR TESTING
2016-07-02 07:51 fman Status new => resolved
2016-07-02 07:51 fman Fixed in Version => 1.9.15 (2015 Q4)
2016-07-02 07:51 fman Resolution open => fixed
2016-07-02 07:51 fman Assigned To => fman
2016-07-02 07:51 fman Relationship added child of 0007262
2016-09-08 15:12 fman Note Added: 0025220
2016-09-08 15:12 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker