Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007489TestLinkUser Interface Generalpublic2016-03-29 15:592016-09-08 15:13
Reporterwardenik 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007489: Username field too short on login screen
DescriptionThe login screen username field is limited to 30 chars on the login screen.
This doesn't make sense,especially when integrating with LDAP when users have their emails as usernames.
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0007262closedfman Availables hot-fixes for 1.9.14 & How To get full fixed package from GitHub 

-  Notes
(0024653)
fman (administrator)
2016-03-29 18:00

I do not like when people start adding sentence like ' This doesn't make sense ', because IMHO is a very bad attitude.
Just report the issue in the right way i.e. without any opinion, and may be results will be better.
(0024655)
wardenik (reporter)
2016-03-29 23:56

I agree that the expression is a bit unfortunate, thanks for pointing that out.
I should have written:
"When integrating with LDAP when users have their emails as usernames, it is quite easy to overflow 30 chars."
(0024662)
fman (administrator)
2016-04-01 18:12

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/a378d41c76db25f29a2fe06aad3c2eabeb121e83 [^]
(0025265)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2016-03-29 15:59 wardenik New Issue
2016-03-29 18:00 fman Note Added: 0024653
2016-03-29 23:56 wardenik Note Added: 0024655
2016-04-01 18:12 fman QA Team - Task Workflow Status => TBD
2016-04-01 18:12 fman Note Added: 0024662
2016-04-01 18:12 fman Status new => resolved
2016-04-01 18:12 fman Fixed in Version => 1.9.15 (2015 Q4)
2016-04-01 18:12 fman Resolution open => fixed
2016-04-01 18:12 fman Assigned To => fman
2016-04-01 18:12 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2016-04-01 18:12 fman Relationship added child of 0007262
2016-09-08 15:13 fman Note Added: 0025265
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker