Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007452TestLinkImport results XML formatpublic2016-02-29 23:322016-09-08 15:12
ReporterMr.Bricodage 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.14 (2015 Q3) 
Fixed in Version1.9.15 (2015 Q4) 
Summary0007452: Import XML results : Import steps results and notes provided in XML file
DescriptionAccording to 0006912, steps tags have been added into "Export for Results Import" XML file to allow import of steps results and notes.

Steps tags are present as specified in 0006912 in exported XML since TL 1.9.13, but steps results and notes are not handled by TL through import result (XML) function.

Steps To Reproduce1) Add a testcase TC1 In a testplan TP1,
2) Use "Export for Results Import" function and download XML file
3) Edit XML file to fill information about test execution (result, exec notes, timestamp, steps results, steps notes)
4) Import XML file to update TC execution
5) Look at detailled execution information through "Test steps exec (print view)"

=> Global information about testcase execution has been imported (result, exec notes, timestamp), information about steps ("execution notes" and "execution status") has been lost.
Additional InformationTested with TL 1.9.14 and with last available Git Hub version

Bug 0006912 point to a "related ticket to allow import" but the related ticket is not linked and I didn't find any ticket about this topic since TL 1.9.12 version.
=> Maybe never opened
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0006912closedfman Export for result import - add tags to allow specify result at step level 

-  Notes
(0025064)
Mr.Bricodage (updater)
2016-07-05 16:29

PR : https://github.com/TestLinkOpenSourceTRMS/testlink-code/pull/40 [^]
(0025096)
Mr.Bricodage (updater)
2016-07-24 11:55

Issue should be marked as resolved in TestLink 1.9.15 : PR has been merged.
(0025211)
fman (administrator)
2016-09-08 15:12

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2016-02-29 23:32 Mr.Bricodage New Issue
2016-07-05 10:13 Mr.Bricodage Relationship added related to 0006912
2016-07-05 16:29 Mr.Bricodage Note Added: 0025064
2016-07-24 11:55 Mr.Bricodage Note Added: 0025096
2016-07-25 15:58 fman QA Team - Task Workflow Status => READY FOR TESTING
2016-07-25 15:58 fman Status new => resolved
2016-07-25 15:58 fman Fixed in Version => 1.9.15 (2015 Q4)
2016-07-25 15:58 fman Resolution open => fixed
2016-07-25 15:58 fman Assigned To => fman
2016-09-08 15:12 fman Note Added: 0025211
2016-09-08 15:12 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker