Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007448TestLinkAssign Test Case Executionpublic2016-02-26 18:302016-09-08 15:13
Reporterbbilter 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIE11OSMS WindowsOS Version7
Product Version1.9.13 (2015 #1) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0007448: Test case results not visible when test case assigned to multiple testers
DescriptionAfter assigning a test case to multiple testers only the first tester the test case was assigned to is able to actually execute the test and save the results. All the remaining testers do not have the bottom half of the test execution screen that allows update of the overall test case and save.
Steps To ReproduceCreate test case.
Assign to multiple TESTERS role in this order, i.e. TESTER1, then TESTER2, then TESTER3
Login as TESTER1 and execute test.
Test case execution results is available to update overall test case status.
Login as TESTER2 and execute test.
The same test case execution results is NOT available to update the overall test case status.
Additional InformationNot sure of the implication but I, as an admin, have access to update the test case status. I tried making, in the above example, TESTER2 an admin role, and they still could not update that test case status.

If I remove all testers from the testcase and then add them back in a different order, whoever i add first is then able to update the test case status.

This was previously reported but not resolved due to lack of follow up:
http://mantis.testlink.org/view.php?id=6661 [^]
http://mantis.testlink.org/view.php?id=6771 [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0024549)
fman (administrator)
2016-02-26 19:03

Please follow this simple guideline
1) if you have found an issue on version N, it will be great if you get version N+1 do a fresh install, retest & provide feedback.

2) You can also access http://mantis.testlink.org/changelog_page.php [^] and give a look to issues solved on Version N+1

waiting for user feedback
(0024552)
bbilter (reporter)
2016-02-26 19:29

Thanks fman - I didn't try the new full version but I found this defectID http://mantis.testlink.org/view.php?id=7112 [^] in the changelog which is the same defect. This was reported as fixed.

Unfortunately I can't upgrade my environment at the moment so I applied the same fix you made to execSetResults.php and it resolved the issue.

Thanks again!
(0025281)
fman (administrator)
2016-09-08 15:13

1.9.15 Released - 2016-09-08

- Issue History
Date Modified Username Field Change
2016-02-26 18:30 bbilter New Issue
2016-02-26 19:03 fman Note Added: 0024549
2016-02-26 19:03 fman Assigned To => fman
2016-02-26 19:03 fman Status new => feedback
2016-02-26 19:29 bbilter Note Added: 0024552
2016-02-26 19:29 bbilter Status feedback => assigned
2016-02-27 09:37 fman QA Team - Task Workflow Status => READY FOR TESTING
2016-02-27 09:37 fman Status assigned => resolved
2016-02-27 09:37 fman Fixed in Version => 1.9.14 (2015 Q3)
2016-02-27 09:37 fman Resolution open => fixed
2016-09-08 15:13 fman Note Added: 0025281
2016-09-08 15:13 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker